CPanel Apache httpd won't start solution: Starting httpd: Syntax error on line 2 of /etc/httpd/conf/httpd.conf: Invalid command 'Alias', perhaps misspelled or defined by a module not included in the server configuration

root@hkhosting [/]# service httpd start
Starting httpd: Syntax error on line 2 of /etc/httpd/conf/httpd.conf:
Invalid command 'Alias', perhaps misspelled or defined by a module not included in the server configuration
                                                           [FAILED]

 

 

root@hkhosting [/]# vi /etc/httpd/conf/httpd.conf

 

One way with CPanel is just to use /scripts/easyapache and rebuild everything since who knows what else has gone wrong if the config file got messed up like that.

This is the entire contents of httpd.conf, it became corrupted somehow.


Alias /mailman/archives /usr/local/cpanel/3rdparty/mailman/archives/public/
Alias /pipermail /usr/local/cpanel/3rdparty/mailman/archives/public/
ScriptAliasMatch ^/?kpanel/?$ /usr/local/cpanel/cgi-sys/redirect.cgi
ScriptAliasMatch ^/?cpanel/?$ /usr/local/cpanel/cgi-sys/redirect.cgi
ScriptAlias /scgi-bin /usr/local/cpanel/cgi-sys/scgiwrap
Alias /java-sys /usr/local/cpanel/java-sys/
Alias /img-sys /usr/local/cpanel/img-sys/
ScriptAlias /cgi-sys /usr/local/cpanel/cgi-sys/
ScriptAliasMatch ^/?whm/?$ /usr/local/cpanel/cgi-sys/whmredirect.cgi
ScriptAliasMatch ^/?securewhm/?$ /usr/local/cpanel/cgi-sys/swhmredirect.cgi
Alias /bandwidth /usr/local/bandmin/htdocs/
Alias /sys_cpanel /usr/local/cpanel/sys_cpanel/
ScriptAliasMatch ^/?securecpanel/?$ /usr/local/cpanel/cgi-sys/sredirect.cgi
ScriptAliasMatch ^/?securecontrolpanel/?$ /usr/local/cpanel/cgi-sys/sredirect.cgi
Include "/usr/local/apache/conf/includes/errordocument.conf"
ScriptAliasMatch ^/?controlpanel/?$ /usr/local/cpanel/cgi-sys/redirect.cgi
ScriptAliasMatch ^/?webmail/?$ /usr/local/cpanel/cgi-sys/wredirect.cgi
ScriptAlias /mailman /usr/local/cpanel/3rdparty/mailman/cgi-bin/
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteMap LeechProtect prg:/usr/local/cpanel/bin/leechprotect
</IfModule>

 


Tags:

cpanel, apache, httpd, syntax, etc, conf, invalid, alias, misspelled, defined, module, included, server, configurationroot, hkhosting, configuration, vi, scripts, easyapache, rebuild, config, contents, corrupted, mailman, archives, usr, rdparty, pipermail, scriptaliasmatch, kpanel, cgi, sys, redirect, scriptalias, scgi, bin, scgiwrap, img, whm, whmredirect, securewhm, swhmredirect, bandwidth, bandmin, htdocs, sys_cpanel, securecpanel, sredirect, securecontrolpanel, quot, includes, errordocument, controlpanel, webmail, wredirect, ifmodule, mod_rewrite, rewriteengine, rewritemap, leechprotect, prg,

Latest Articles

  • How to combine .txt ACLs without breaking things
  • How to ping all of Googlebot's IPs script
  • 'virtio0' uses a qcow2 feature which is not supported by this qemu version: QCOW version 3
  • Linux bash script to get the IP of a list of hostnames
  • How To Use Camera Webcam in Docker for OBS Studio etc...
  • Computer Server Won't Post Boot Or Enter BIOS Setup After Installing RAID SAS or GPU Card etc..
  • How To Test PHP Scripts from CLI with GET variables/query string
  • apt-cache how to see all available versions of a package in Debian Ubuntu Mint
  • Virtualbox VBox Guest-utils drag and drop files stops working with Windows VMs
  • How To Remove Ubuntu Netplan and Go Back to /etc/network/interfaces
  • How To Force Flash an AMD Instinct GPU To Another Model Using Debian Ubuntu Mint Linux
  • How To compile ollama from source to use unsupported AMD GPU with rocm in Ubuntu Debian
  • QEMU KVM Virtio GPU Windows Cannot Select 1080P
  • Linux Gnome Desktop Ubuntu Mint Debian Gets Slower After Weeks
  • Firefox How to Save Full Page As Screenshot/PDF
  • Nvidia Datacenter Driver Tesla Slow nvidia-smi response and high utilization with 0 usage
  • ffmpeg how to normalize / increase the volume of your audio
  • kdenlive audio blips pops cracks artifacts solution fix
  • haproxy / nginx certbot SSL issues
  • nginx how to see the real IP when behind a CDN