• ADATA USB Thumb Drive Issues


    This is the reason that I don't like the new ADATA USB drives such as the UV128/64GB or 128GB drives and other ones that look to be the same style (the green sliding USB connector). They just don't work well from new and never work properly at any point. [ 788.242463] usb 1-1.2: new high-speed USB device number 16 using ehci-pci [ 788.339816] usb 1-1.2: New USB device found, idVendor=125f, idProduct=db8a [ 7........
  • Why SMART is not smart at all and doesn't properly predict disk errors that cause a kernel panic or crash


    Before getting into the output here is my typical experience with SMART, there is what I call a "bad disk" with pending and uncorrectable sectors that cannot be reallocated. It has caused a kernel panic and system crash repeatedly as we can see from the logs. But SMART says it has "PASSED" its self assessment. SMART is still useful to me but it is more about looking at Current_Pending_Sector. Any time I have had anything but 0 for that attribute it........
  • USB Device/MP3 Player not working properly and can't browse the device filesystem? Check the cable twice and again!


    Here is a simple MP3 player and now there's a reason to understand why the supplied cable has some kind of capacitor and is very short. These devices can be VERY finicky and any voltage fluctuation or difference is enough to cause issues. Take for example the error messages from Linux Mint: [804829.895414] usb 1-1: USB disconnect, device number 11 [806961.109030] usb 1-1: new high-speed USB device number 12 using xhci_hcd........
  • Linux shows my drive as being dead is it really? Buffer I/O error on device sdb, logical block 0 sd 3:0:0:0: [sdb] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00


    Normally the below would indicate a failing or failed drive. In this case the SATA port was unplugged and sometimes the Linux kernel/motherboard even with AHCIjust don't play nice and can't handle it. What happened is Iplugged in a new drive after removing another one. However the log shows that after the old drive was plugged in the Linux kernel kept complaining thinking the drive was there but not responding properly. This continued even with reseating........
  • What happens when you unplug 1 or more devices from an mdadm RAID array to simulate a failure in Linux Ubuntu/Centos/Debian?


    In short the two drives in the array were /dev/sdd and /dev/sde. The kernel sees they were unplugged and have gone down as you can see below. mdadm caught the first one being unplugged /dev/sde and disabled the missing drive. However when the final drive that was part of the array is unplugged it didn't notice at all. Instead it complains about an IO error later for drives that the kernel knows do not exist anymore. [45817.162728] ata4: exception........
  • What a hdd hard drive and mdadm RAID array failure looks like in Linux


    [3805108.257042] sd 0:0:0:0: [sda] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB) [3805108.257052] sd 0:0:0:0: [sda] Write Protect is off [3805108.257054] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00 [3805108.257066] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA [3805108.257083] sd 0:0:0:0: [sda] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB) [3805108.257090] sd 0:0:0:0: [sda] Write Protect is off........
  • Brand new WDD 500GB Blue 3.5 SATA Drive Dead After Shipping


    These drives seem to die very easily during shipping: sd 0:0:0:0: [sda] Unhandled error code sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK sd 0:0:0:0: [sda] CDB: Read(10): 28 00 18 8b 65 e0 00 00 08 00 end_request: I/O error, dev sda, sector 411788768 sd 0:0:0:0: [sda] Unhandled error code sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK sd 0:0:0:0: [sda] CDB: Read(10): 28 00 18 8b........
  • WD 20EARX 2TB Bad within days


    This is just trying to read 5GB off the drive with dd and the drive initially tested ok but shortly after I wondered why I was seeing 2MB/s read speeds. Notice the "current_pending_sector", anytime I've seen it at anything above 0 even with no other bad fields/attributes, it means the drive is bad. ata1.00: exception Emask 0x0 SAct 0x3 SErr 0x0 action 0x0 ata1.00: irq_stat 0x40000008 ata1.00: failed command: READ FPDMA QUEUED ata1.00: cmd 60/00:00:........
  • Strange SATA error code when turning on HDD/Hard drive - [1433128.139339] sd 5:0:1:0: [sde] Unhandled error code [1433128.139343] sd 5:0:1:0: [sde] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK [1433128.139348] sd 5:0:1:0: [sde] CDB: Read(10):


    [1433128.139339] sd 5:0:1:0: [sde] Unhandled error code [1433128.139343] sd 5:0:1:0: [sde] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK [1433128.139348] sd 5:0:1:0: [sde] CDB: Read(10): 28 00 00 00 00 00 00 00 08 00 [1433128.139360] end_request: I/O error, dev sde, sector 0 [1433128.139410] sd 5:0:1:0: [sde] Unhandled error code [1433128.139414] sd 5:0:1:0: [sde] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK [1433128.139420] sd 5:0:1........
  • Dying Samsung DVDRW Drive


    My Samsung drive failed on me, at first I thought it was the enclosure but a direct SATA connection causes the same problems for discs that are inserted. It will work fine for a few minutes but then starts spewing the errors below. I've never been a fan of Korean made optical drives and have always had trouble with them. The problem is that I don't believe NEC and Lite-ON make drives anymore, and I considered them the leaders. Apr 7 11:58:48 bo........
  • mdadm when a RAID 1 member dies


    [27969.398749] sd 5:0:0:0: [sdb] 3907029168 512-byte hardware sectors (2000399 MB) [27969.398749] sd 5:0:0:0: [sdb] Write Protect is off [27969.398749] sd 5:0:0:0: [sdb] Mode Sense: 00 3a 00 00 [27969.398749] sd 5:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA [27972.117543] ata6.00: exception Emask 0x0 SAct 0x1 SErr 0x0 action 0x0 [27972.117543] ata6.00: irq_stat 0x48000000 [27972.117543] ata6.00: cmd 60/08:00:ff:7........
  • Seagate Drive 500GB Drive Dying


    This drive is clearly on the way out, the Kernel knows it but I'm surprised that SMART is not concerned. I didn't blame Seagate for their past issues until now. This hard drive has hardly been used and has not even been powered on for a year according to SMART. Home page is http://smartmontools.sourceforge.net/ === START OF INFORMATION SECTION === Model Family: Seagate Barracuda 7200.11 Device........
  • Latest Articles

  • CentOS 7 8 How To Disable SELinux
  • Wordpress How To Add Featured Image To Post in Hueman Theme
  • kdenlive full reset how to erase all config files
  • CentOS 7 8 yum error Trying other mirror. To address this issue please refer to the below wiki article
  • Microsoft Teams Linux - Calendar Doesn't Work Missed Meetings!
  • Scanner not working in Linux Ubuntu Fedora Mint Debian over the network? Use sane-airscan!
  • How To Boot, Install and Run Windows 2000 on QEMU-KVM
  • bash cannot execute permission denied
  • Huion and Wacom Tablets How To Install in Linux Mint / Ubuntu and make the stylus work properly
  • ffmpeg how to cut certain parts of video out
  • ffmpeg how to concat and join two video clips
  • mencoder instead of ffmpeg to join or concatenate video files with different audio streams
  • Linux How To Stop Missing Drive from Halting Boot Process in fstab
  • How To Replace Audio Track of Video using ffmpeg
  • qemu-img convert formats vdi vmdk raw qcow2
  • Linux and Windows Dual Boot Crazy Time Issues
  • dynagen / dynamips 100% high CPU usage solution - how to set the idlepc value
  • How To Setup a Cisco CME (Cisco Manager Express) Virtual Router under Linux using dynamips and dynagen
  • Linux Mint Ubuntu Debian CentOS Dual Boot Install Issues
  • Linux Mint Ubuntu Debian Centos RHEL no sound solution