/ - rtt - IT Resource

  • How to download gajim 0.16.9 XMPP/Jabber client so you can use OMEMO encryption


    #Linux Mint 18.2 how to install gajim .16.9 so you can use OMEMO encryption: sudo apt-get install python-axolotl python-nbxmpp wget https://gajim.org/downloads/0.16/gajim-0.16.9.tar.gz tar -zxvf gajim-0.16.9.tar.gz cd gajim-0.16.9 ./autogen.sh ;make;sudo make install #if you get this error you need to get a newer python-nbxmpp from here: gajim Gajim needs python-nbxmpp >= 0.6.1 to run. Quiting...........
  • Centos 7 - How To Install NFS and Mount Remotely


    1.) First install nfs-utils [root@bcitcourse ~]# yum -y install nfs-utils Loaded plugins: fastestmirror base                                                         &n........
  • Linux Mint missing ffmpeg solution to install from Ubuntu PPA


    This is very annoying that ffmpeg is missing from Linux Mint!  They have ffmpeg2theora which is a totally different codec and does not work as ffmpeg does at all (it is basically totally different). However on Linux Mint 17 I was able to use a Ubuntu PPA and sucessfully install ffmpeg! https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media Adding this PPA to your system........
  • Cannot get mono to work properly on Linux Mint


      mono/wine not working in Ubuntu/Linux Mint/Debian: The assembly mscorlib.dll was not found or could not be loaded. It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.   solution: sudo apt-get install mono-complete      Problems: mono does not work well for even simple things like a Winrar self extracting .exe fi........
  • Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again


    Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again You have to upgrade the ca-certs for epel but need to disable it before that can happen. yum upgrade ca-certificates --disablerepo=epel........
  • How to update Open Office in Ubuntu/Debian if your repository is outdated or no longer supported


    http://sourceforge.net/projects/apacheoo-deb/files/debian/dists/wheezy/main/binary-i386/ To install AOO on your computer, you need to add the following entry to the /etc/apt/sources.list file: deb http://downloads.sourceforge.net/project/apacheoo-deb/debian wheezy main sudo apt-get update && sudo apt-get install openoffice-en* openoffice-brand-writer openoffice-brand-calc openoffice-brand-impress openoffice-brand-base open........
  • Dell Perc 6/i cannot downgrade


    I flashed an LSI Logic firmware to it and it broke the BIOS (cannot do Ctrl+R) for booting purposes but allows other functionality to work normally. I tried downgrading to a Dell firmware for Perc 6i but it won't work, not even with MegaCli wget http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN --2013-08-26 12:53:39--  http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN Resolvi........
  • Directadmin error/** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows: e2fsprogs-devel-1.41.12-3.el6.i686 has missing requires of e2fsprogs-libs = ('0', '1.41.12', '3.el6') e2fsprogs-devel-1.41.12-3.el6.i686 has missing requires of l


    Solution To The Following: yum -y install zlib-devel yum -y install e2fsprogs* *** Cannot find /usr/include/et/com_err.h.  (yum install libcom_err-devel) *** Installation didn't pass, halting install. Once requirements are met, run the following to continue the install:   cd /usr/local/directadmin/scripts   ./install.sh Common pre-install commands:  http://help.directadmin.com/it........
  • Centos how to upgrade from PHP 5.2 to 5.3 without downtime


    This may sound silly but there will be conflicts/issues with the default Centos repository so you have to use a third party like remi (I prefer not to do this but it's the only option unless you migrate your sites/data to another server or can stand some downtime-not an option IMHO on a production server). You may need to upgrade to PHP 5.3 to run Joomla or many other reasons. Your host needs to use PHP 5.2.4 or higher to run this version of Jo........
  • Openvz YUM Error Solution to "[Errno -1] Metadata file does not match checksum Trying other mirror."


    It's weird because I have a nearly identical box and setup and I can update the ovzkernel-PAE* just fine but on this box it doesn't work. I only get this error with the openvz.repo and not others such as Centos-Base.repo With my other server it works normally: ================ Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package ovzkernel-PAE.i686 0:2.6.18-238.12.1.el5.0........
  • vnstat setup guide/tutorial


    yum -y install vnstat chown nobody.nobody -R /var/lib/vnstat/ #replace venet0 below with your desired interface sudo -u nobody vnstat -u -i venet0 #edit: vi /etc/sysconfig/vnstat #VNSTAT_OPTIONS="-i venet0" # only use the sed below if you are using venet0 instead of eth0 or replace accordingly sed -i 's/eth0/venet0/g' /etc/sysconfig/vnstat   [root@monitor]# yum install vn........
  • yum in Centos 5/Xen halts and exits suddenly


    yum exits in the middle The problem is this VPS seems to be an OpenVZ template from HyperVM.  The only way to make it work was to disable i386 packages since this was an x64 kernel.  That shouldn't be necessary but it was the only way to make yum stop quitting after the first package or two.  I couldn't find any issue by checking the logs either. echo y|yum install vim-minimal telnet expect jwhois net-tools slocate iptables elinks gawk L........
  • http://apt.sw.be/redhat/el5/en/i386/test/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found Trying other mirror.


    http://apt.sw.be/redhat/el5/en/i386/test/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmforge-testing. Please verify its path and try again Notice it is complaining about "rpmforge-testing", just disable it for now: Solution is to edit the repo: vi /etc/yum.repos.d/rpmforge-testing.repo........
  • Picking an FTPD (vsftpd) Server in Linux Centos/Debian


    I decided on using yum to help me decide even though I normaly use proftpd I decided to see what else I could find. yum search ftp Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile  * rpmforge: ftp-stud.fht-esslingen.de  * base: mirrors.netdna.com  * updates: updates.interworx.info  * addons: yum.singlehop.com  * extras: mirrors.netdna.com rpmforge   ........
  • PHP cannot access /usr/bin/openssl


    PHP cannot access /usr/bin/opensslI have verified the username that runs the process is able to access /usr/bin/openssl and it does exist but the PHP script is saying it doesn't exist: [code:1:1fd0f3abbe] if (!file_exists($OPENSSL)) { //echo "ERROR: OPENSSL $OPENSSL not foundn"; }[/code:1:1fd0f3abbe] I don't get itI can clearly see the contents of /usr/bin by using the PHP system fu........
  • Updating yum repos for DAG /etc/yum.repos.d


    Updating yum repos for DAG /etc/yum.repos.dIn /etc/yum.repos.d [quote:96456b2ab9]Create any file such as "CentOS-Dag.repo" in /etc/yum.repos.d[/quote:96456b2ab9] Add the following to the above file: [code:1:96456b2ab9] [dag] name=Dag RPM Repository For Red Hat Enterprise Linux baseurl=http://dag.atrpms.net/redhat/el$releasever/en/$basearch/dag/ http://dag.freshrpms.net/redhat/e........
  • sudo: Error dropping capabilities, aborting in Linux Centos 5.3


    For some reason I keep getting this error when trying to run a sudo command eg: sudo -u someuser somecommand sudo: Error dropping capabilities, aborting My version of sudo is: sudo-1.6.9p17-3.el5_3.1 and I've heard that version 1.7 fixes everything.  The only thing is yum does not think sudo has any update.  I guess the new version has not been committed to the RPM repository yet. This is really a huge and ann........
  • Using a Mac OSX DMG Image in Windows and Converting to Standard ISO Format use dmg2iso


    The dmg format is silly and annoying to work with, why couldn't Apple stick with the .iso standard?  Anyway, there's an excellent Linux and Windows based tool to convert it back to a normal .iso Image called dmg2iso I'll only cover the Linux version although the Windows pre-built binary works the same way. Download dmg2iso here for free (from the author's website) It's just silly and doesn't make sense that Ubuntu doe........
  • Latest Articles

  • syntax error, unexpected T_SL in PHP Solution
  • grep regular expression match number range between specific numbers
  • bash how to print out lines of text within a range from the first occurrence
  • bash script how to to check LAN computers for open ports
  • MySQL Using mytop Debug Source of High IO and Slow Performance
  • How To Mathematically Convert and Calculate Binary Value To Decimal Value
  • systemd management using systemctl and journalctl to check systemd logs
  • css how to format code in the code tag
  • css br with extra blank line
  • What is /dev/pts and why do we need it in Linux?
  • Linux What is umask (user mask) for file and directory creation permissions and how to calculate umask and change the defaults
  • Linux Permissions and Groups Real Usecase for Group Access
  • Centos 7 python34 how to install the gi library
  • Centos 7 - Convert Minimal to Graphical GUI GNOME or KDE Desktop
  • AMD Set Fan Speed and Other Powerplay Memory/CPU Timings with a Linux script
  • Ethereum Mining Claymore Nanopool Error
  • genisoimage errors with long filenames and deep directory structures
  • Linux Kernel USB Export Errors
  • How to download gajim 0.16.9 XMPP/Jabber client so you can use OMEMO encryption
  • HP DL385 G7 Linux BIOS Update Flash