• *** These critical programs are missing or too old: gawk


    checking whether autoconf works... ../configure: line 5377: 7325 Segmentation fault $AUTOCONF $ACFLAGS configure.in > /dev/null 2>&1 no configure: error: *** These critical programs are missing or too old: gawk *** Check the INSTALL file for required versions. ........
  • wodim / cdrecord error cannot burn DVD or BDR .iso Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error


    dvd+rw-mediainfo /dev/sr0 INQUIRY: [ASUS ][BW-16D1HT ][3.00] GET [CURRENT] CONFIGURATION: Mounted Media: 11h, DVD-R Sequential Media ID: RITEKF1&n........
  • PHP geoip.so fatal error Solution


    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/geoip.so' - /usr/lib64/php/modules/geoip.so: undefined symbol: GeoIP_country_code_by_name_v6 in Unknown on line 0 Remove the GEOIP from PHP: php71w-pecl-geoip-1.1.1-1.w6.x86_64 PHP Fatal error: PHP Startup: apc_shm_create: shmget(0, 67108864, 914) failed: Invalid argument. It is possible that the........
  • ffmpeg Linux Mint download, compile and install howto


    #if you have nvidia make sure you install the nvidia-cuda-toolkit so hardware acceleration can be used wget http://ffmpeg.org/releases/ffmpeg-3.3.2.tar.bz2 tar -jxvf ffmpeg-3.3.2.tar.bz2 cd ffmpeg-3.3.2/ ./configure --disable-yasm install prefix /usr/local source path ........
  • apc_shm_attach: shmat failed: in Unknown on line 0 & apc_shm_create: shmget(0, 67108864, 914) failed PHP Solution


    PHP Fatal error: PHP Startup: apc_shm_create: shmget(0, 67108864, 914) failed: Invalid argument. It is possible that the chosen SHM segment size is higher than the operation system allows. Linux has usually a default limit of 32MB per segment. in Unknown on line 0 PHP Fatal error: PHP Startup: apc_shm_attach: shmat failed: in Unknown on line 0 This error is not at all fun because it actually prevents Apache/httpd from starting or working at all. It will........
  • Linux Mint Network Manager Connection Disconnect Option Grayed Out


    This is a real pain because I had to manually unplug ethernet cables for network testing or to use an alternate network or guarantee physical access to one network segment is cut off. For some reason this happened after Ikilled dbus because it was confused and blocking packets thinking they were coming from the wrong interface since eth0 and eth1 both had the same subnet and gateway. I eventually did a "service network-manager restart" but the option was........
  • LVM Tutorial how to create a Physical Volume (PV), Volume Group (vg), and a Logical Volume (LV) within it


    # first we need a physical volume which we use the pvcreate tool to create # I create mine on /dev/sdb3 pvcreate /dev/sdb3 dev_is_mpath: failed to get device for 8:19 Physical volume "/dev/sdb3" successfully created # pvdisplay shows the newly created volume pvdisplay "/dev/sdb3" is a new physical volume of "1.35 TiB" --- NEW Physical volume --- PV N........
  • Directadmin Install Segfault Error


    ************************************* * * * All parts have been installed * *........
  • Xen how to mount disk images off-line and access data


    fdisk -lu VPS.img last_lba(): I don't know how to handle files with mode 81ed You must set cylinders. You can do this from the extra functions menu. Disk VPS.img: 0 MB, 0 bytes 255 heads, 63 sectors/track, 0 cylinders, total 0 sectors Units = sectors of 1 * 512 = 512 bytes Device Boot Start End ........
  • rpmforge: [#### ] 471/10722Segmentation fault yum[18934]: segfault at 0000000000000000 rip 00002ade62153a30 rsp 00007fff76f9fe58 error 4


    A few days ago this happened on multiple Centos 5 servers and apparently anyone using rpmforge was affected by this error and there was no solution other than disabling that repo to fix it. To some this highlighted a few points, that there is a reason RHELexists with full paid support, and also that this could be a vulnerability and huge flaw with yum. A yum search or install should not segfault just because the rpmforge repo goes down. Fortunately it came back up........
  • LAME MP3 Encoder Segmentation Faults


    This happened on one of my Ubuntu machines where Igot some kind of segfault on line 21 from LAME at random while encoding MP3s (a second try is fine usually). I've read that it's best to compile it from source and that has solved most issues for people. Here is my preferred configure line: ./configure --enable-mp3x --with-fileio=lame --enable-debug --with-vorbis Even with that I got a different error this tim........
  • Latest Articles

  • chown how to change ownership on a symlink
  • how to use ifplugd in Linux to execute a command or script when a NIC cable is unplugged or plugged in
  • dd how to backup and restore disk images including compression with gzip
  • mpv / mplayer with Radeon / AMD GPU Video Card Driver enable VDPAU GPU Accelerated Video Decoding
  • Wordpress Reset Blog User Password from MySQL Using Linux Bash and not PHPMyadmin
  • Ubuntu Linux Mint Debian xorg performance and tear-free tuning for AMD Radeon Based Cards
  • Centos 7 Stopped and Disabled Firewalld and ports still blocked
  • MariaDB / MySQL Reset Root Forgotten Password on Centos 7
  • Centos 7 How to install Mysql/Mariadb
  • PHP 7.2, Apache and Centos 7 How To Install
  • Ubuntu Debian Linux Mint r8169 r8168 Network Driver Problem and Solution
  • Linux 3D Performance benchmarks with glxgears 59-60fps solution
  • How To Install Asterisk 16 17 on Debian Ubuntu Linux
  • Linux Ubuntu Debian Centos How To Make a Bootable Windows 7, 8, 10, 2016, 2019 Server USB from ISO
  • How To Restore Windows MBR Bootsector from Linux using syslinux
  • Linux Ubuntu Cannot Print Large Images
  • Cannot Print PDF Solution and Howto Resize
  • Linux Console Login Screen TTY Change Message
  • Apache Cannot Start Listening Already on 0.0.0.0
  • MySQL Bash Query to pipe input directly without using heredoc trick