yum error installing php solution - exclude php from being installed from third party repos

Error: Package: php-Monolog-dynamo-1.7.0-1.el6.noarch (epel)
           Requires: php-aws-sdk
Error: php-pecl-zendopcache conflicts with 1:php-eaccelerator-0.9.6.1-1.el6.x86_64
Error: php-xcache conflicts with php-pecl-apc-3.1.9-2.el6.x86_64
Error: php-pecl-zendopcache conflicts with php-pecl-apc-3.1.9-2.el6.x86_64
Error: Package: php-horde-Horde-Vfs-2.1.2-2.el6.noarch (epel)
           Requires: php-pecl(ssh2) >= 0.12
           Installing: php-pecl-ssh2-0.11.0-7.el6.x86_64 (epel)
               php-pecl(ssh2) = 0.11.0
Error: php-pecl-apc conflicts with 1:php-eaccelerator-0.9.6.1-1.el6.x86_64
Error: php-pecl-apcu conflicts with php-pecl-apc-3.1.9-2.el6.x86_64
Error: php-pecl-gmagick conflicts with php-magickwand-1.0.9-1.el6.x86_64
Error: php-xcache conflicts with 1:php-eaccelerator-0.9.6.1-1.el6.x86_64
Error: php-pecl-zendopcache conflicts with php-xcache-3.0.4-1.el6.x86_64
Error: php-xcache conflicts with php-pecl-zendopcache-7.0.3-1.el6.x86_64
Error: php-pecl-http1-devel conflicts with php-pecl-http-devel-2.0.4-1.el6.x86_64
Error: php-ZendFramework2-common conflicts with php-ZendFramework-1.12.3-1.el6.noarch
Error: php-pecl-apcu-devel conflicts with php-pecl-apc-devel-3.1.9-2.el6.x86_64
Error: php-pecl-gmagick conflicts with php-pecl-imagick-2.2.2-4.el6.x86_64
Error: php-pecl-http1 conflicts with php-pecl-http-2.0.4-1.el6.x86_64
Error: php-pecl-http conflicts with php-pecl-http1-1.7.6-4.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Edit all repos in /etc/yum/repos.d/* to exclude=php* (the problem is that repos like rpmforge elrepo, epel have PHP and it ends up conflicting and creating upgrade/install issues with the PHP that comes from the main Centos repo)


Tags:

yum, installing, php, exclude, installed, reposerror, monolog, dynamo, noarch, epel, requires, aws, sdk, pecl, zendopcache, conflicts, eaccelerator, _, xcache, apc, horde, vfs, ssh, apcu, gmagick, magickwand, http, devel, zendframework, imagick, rpm, va, nofiles, nodigest, edit, repos, etc, rpmforge, elrepo, conflicting, creating, upgrade, install, centos, repo,

Latest Articles

  • CentOS 6 impossible to compile a newer libguestfs
  • chroot
  • How To Get Started on Ubuntu with gpt-2 OpenAI Text Prediction
  • Remove cloud-init in your VM
  • QEMU-KVM KVM Command Line Practical Guide
  • Linux How To Change NIC Name to eth0 instead of enps33 or enp0s25
  • virt-resize: error: libguestfs error: could not create appliance through libvirt.
  • Asterisk Does Not Retry When Authentication Fails
  • Linux Debian Ubuntu How To Install PEPPER Faster and Latest Adobe Flash Player in Firefox
  • How To Speed Up Linux Ubuntu and Debian Based Computers By Improving CPU Performance and Changing the CPU Governor
  • Convert data or file to base64 on a single line
  • Linux Mint Ubuntu Debian radeon slow 2D performance issues radeon_dp_aux_transfer_native: 158 callbacks suppressed
  • mdadm: super0.90 cannot open /dev/sdb1: Device or resource busy mdadm: /dev/sdb1 is not suitable for this array.
  • How To Install NextCloud on Centos 7 and Centos 8
  • AH01630: client denied by server configuration:
  • ERROR: Could not find a version that satisfies the requirement PIL (from versions: none) ERROR: No matching distribution found for PIL
  • ZTE Camera Cannot Work unable to connect to camera. Camera has been disabled becaue of security policies or is being used by other apps
  • QEMU KVM how to boot off a physical CD/DVD/BDROM Drive
  • How To Install OpenProject on Centos 7 Step-by-Step Guide
  • Ubuntu Debian Linux Cannot Install Wine Solution - wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu14.2) but it is not installable wine1.4 : Depends: wine1.6 but it is not going to be installed