• Cisco Unified Communications Manager / CUCM IP 8.6,10,12 Install Error Solution


    Install Errors on Version 12: This error happened on QEMU emulator version 2.11.1 pve-qemu-kvm_2.11.1-5 on Proxmox/Debian but installing on QEMU.12 on Centos 6 did not produce the error. *Update it is not related to the OS or QEMU version. This happened in Centos 6 too after a second install. What really causes this even though you successfully install........
  • Cisco Unified Communications Manager 12 Install Errors on Proxmox/KVM


    The strange thing is that usually the first install or two will work on any new machine but then it suddenly won't. I had this experience on QEMU 2.13 on a different machine. There is something finicky or buggy about the CUCM installer even when choosing the same virtual hardware specs. qemu-kvm command: /usr/libexec/qemu-kvm -version QEMU PC emulator version 0.12.1 (qemu-kvm-0.12.1.2-2.506.el6_10.1), Copyright (c) 2003-2008 Fabrice Bellard ........
  • How to install and setup LXC Containers (OpenVZ alternative) on Centos 6 / 7


    If you don't aleady have it, you'll need EPEL Install LXC yum -y install lxc lxc-templates Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirror.it.ubc.ca * epel: mirrors.kernel.org * extras: mirror.it.ubc.ca * updates:........
  • iSCSI on Centos 7 Configuration and Setup Guide for Initiator and Target


    initiator = client target = server These are the first concepts you should understand which is that in iscsi essentially the "initiator" is the client and the "target" is the server. iSCSI is derived from the old fashioned SCSI that us oldtimers grew to love. The "i" stands for Internet and the SCSI stands for "Small Computers Systems Interface" (SCSI). iSCSI Target (Server)Setup targetcli is the pac........
  • Linux Centos 7 HowTo Install Yarn


    https://yarnpkg.com/lang/en/docs/install/#centos-stable curl --silent --location https://dl.yarnpkg.com/rpm/yarn.repo | tee /etc/yum.repos.d/yarn.repo If you need node.js: curl --silent --location https://rpm.nodesource.com/setup_6.x | bash - yum install nodejs yarn........
  • Centos 7 - How To Install NFS and Mount Remotely


    Server Side Config 1.) First install nfs-utils yum -y install nfs-utils 2.) Configure nfs share Create a directory for your NFS share mkdir /datastore Create your NFS share in /etc/exports echo "/datastore 10.220.101.0/24(rw,sync,no_root_squash)" >> /etc/exports systemctl restart nfs........
  • VMWare 6.7 VCSA VSphere ESXi Management SSO Install Guide on Linux using the CLI


    #mount the VCSA DVD mount /dev/sr0 /mnt/cd #alternatively you could mount the iso directly mount -o loop vcsa.iso /your/mount/path #for this purpose we are using the CLI installer on Linux cd /mnt/cd/vcsa-cli-installer/lin64 #no it's not going to be that easy you can't just run vcsa-deploy like that you need to use a template or configured .json file ./vcsa-deploy Usage: vcsa-deploy [-h] [--version] [--supported-deploymen........
  • Centos 5.9 Working Vault Repo file


    Centos 5 is not supported running yum will produce an error like this: YumRepo Error: All mirror URLs are not using ftp, http[s] or file. Eg. Invalid release/ removing mirrorlist with no valid mirrors: /var/cache/yum/base/mirrorlist.txt Error: Cannot find a valid baseurl for repo: base Solution - Update this file CentOS-Base.repo # CentOS-Base.repo........
  • Centos 7 Cudaminer Nvidia setup guide


    I am using a GTX 1060 but replace the download for the driver with the correct/current version for your particular card by visiting: http://www.nvidia.com/Download/index.aspx?lang=en-us yum install automake curl openssl-devel libcurl-devel gcc gcc-c++ yum -y install kernel-devel-`uname -r` yum -y install unzip #the........
  • grubby fatal error: unable to find a suitable template solution Centos


    vzkernel-2.6.32-042stab116.2.x86_64.rpm&n........
  • OpenVZ Install Guide Again / Quick Setup


    yum -y install wget wget -P /etc/yum.repos.d/ http://ftp.openvz.org/openvz.repo rpm --import http://ftp.openvz.org/RPM-GPG-Key-OpenVZ yum -y install vzkernel vzctl #enable ip_forward sed -i s/'net.ipv4.ip_forward = 0'/'net.ipv4.ip_forward = 1'/g /etc/sysctl.conf #all interfaces should not send redirects echo "net.ipv4.conf.default.send_redirects = 1" >> /etc/sysctl.conf echo "net.ipv4.co........
  • dir2slideshow Centos rpm requirements


    yum -y install dvdauthor ffmpeg mjpegtools sox bc rpm -ivh dvd-slideshow-0.8.4-2.noarch.rpm Preparing... ########################################### [100%] 1:dvd-slideshow ########################################### [100%] /usr/bin/dir2slideshow: line 553: bc: command not f........
  • cPanel how to force reinstall rpms and fix packages and other problems caused by updates or duplicate rpms


    If a service is not working and resetting it to defaults is not working and you get bizarre error messages it is probably a broken update and possibly duplicate package. Take in this case "exim" not working even after resetting to defaults. Check for duplicates: rpm -aq|grep exim ........
  • Centos scp or sftp program missing solution/what rpm provides them


    You need the "openssh-clients" package which contains sftp and scp. yum -y install openssh-clients........
  • CPanel Link to all of the command line options


    CPanel says you can access 98% of the functions through CLI which experienced Unix/Linux admins prefer for simplicity and for scripting.  I've never found CPanel easy to use from the admin panel, it seems everything is hard to find and a simple task becomes a series of hunts. So for people like me here's the list: http://cpanel.net/system-administrators/command-line-scrip........
  • mytop install errors


    mytop-1.4-2.el5.rf.noarch from rpmforge has depsolving problems --> Missing Dependency: perl(DBI) is needed by package mytop-1.4-2.el5.rf.noarch (rpmforge) solution: #disabling excludes is required on CPanel type boxes which exclude most updates including perl-DBI yum --disableexcludes=main install perl-DBI mytop-1.4-2.el5.rf.noarch from rpmforge has depsolving problems --> Missing Dependency:........
  • heartbeat compile errors with rpmbuild


    c1: warnings being treated as errors stonith_signal.h:34: error: 'stonith_signal_set_simple_handler' defined but not used gmake[3]: *** [apcmaster.lo] Error 1 gmake[3]: Leaving directory `/root/rpmbuild/BUILD/heartbeat-1.2.4/lib/plugins/stonith' gmake[2]: *** [all-recursive] Error 1 gmake[2]: Leaving directory `/root/rpmbuild/BUILD/heartbeat-1.2.4/lib/plugins' gmake[1]: *** [all-recursive] Error 1 gmake[1]: Leaving directory `/root/rpmbuild/BUI........
  • yum error "Error: database disk image is malformed" solution


    yum -y install mathtools Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: centos.mirror.rafal.ca * epel: mirror.steadfast.net * extras: mirror.agmn.ca * rpmforge: repoforge.mirror.constant.com * updates: centosb5.centos.org extras ........
  • OpenVZ mismatched kernel and dev when compiling.


    ./configure ./configure: line 91: cd: /lib/modules/2.6.32-042stab084.25/build: No such file or directory Error: kernel version not found. Please make sure your kernel is configured. dr-xr-xr-x. 4 root root 4096 Feb 21 06:13 .. lrwxrwxrwx 1 root root 45 Feb 21 06:13 build -> ../../../usr/src/kernels/2.6.32-042stab084.25 drwxr-xr-x 2 root root 4096 Feb 12 20........
  • yum Centos 386 and 64 bit conflict resolution


    This can happen when you install RPMForge or other repos with the wrong architecture and here's how you fix it (simply uninstalling won't usually fix it): solution yum clean all yum -y install openvpn Loaded plugins: fastestmirror, presto Loading mirror speeds from cached hostfile * base: mirror.its.sfu.ca * extras: centos.mirror.nexicom.net * rpmforge: mirror.cpsc.ucalgary.ca * up........
  • OpenVZ Quick Install Copy & Paste for Centos 6


    yum -y install wget wget -P /etc/yum.repos.d/ http://ftp.openvz.org/openvz.repo rpm --import http://ftp.openvz.org/RPM-GPG-Key-OpenVZ yum -y install vzkernel vzctl After that just reboot and you may also have to enable ip_forward in /etc/sysctl.conf........
  • yum error installing php solution - exclude php from being installed from third party repos


    Error: Package: php-Monolog-dynamo-1.7.0-1.el6.noarch (epel) Requires: php-aws-sdk Error: php-pecl-zendopcache conflicts with 1:php-eaccelerator-0.9.6.1-1.el6.x86_64 Error: php-xcache conflicts with php-pecl-apc-3.1.9-2.el6.x86_64 Error: php-pecl-zendopcache conflicts with php-pecl-apc-3.1.9-2.el6.x86_64 Error: Package: php-horde-Horde-Vfs-2.1.2-2.el6.noarch (epel) &n........
  • Centos Howto Upgrade to PHP 5.3 from 5.2


    It's not as simple as "yum install" as you can see below and it doesn't stop there. yum install php53 Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * rpmforge: mirror.us.leaseweb.net * extras: centos.mirror.rafal.ca * updates: centos.mirror.nexicom.net * base: centos.mirror.nexicom.net * addons: centos.mirror.nexicom.net Setting up Install Process........
  • rpmforge Centos 6 how to install


    rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt i686: rpm -ivh http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.i686.rpm x64: rpm -ivh http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm ........
  • Centos 5,6,7 Install EPEL from Fedora for extra packages Howto


    http://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F Visit the above URL, choose your version and architecture and install it. EPELhas a lot of missing and extra packages that rpmforge does not. For Centos 5 #update EPEL for Centos 5 is now archived and not really supported but can be downloaed from here:........
  • Dell Perci 6/i Firmware Upgrade Guide Tutorial


    One thing to remember is that you need MegaCli to do the flashing. You also need the correct file,I tried at least 2 different Perc 6 firmwares from Dell that kept getting rejected as corrupt by MegaCli(they were really the wrong version). I have an external PCI-E Dell 6 Perc/I butI chose images from the 'Integrated" on motherboard version as it was allI could find. They are different, and below is my first time finding success.........
  • Dell Perc 6/i cannot downgrade


    I flashed an LSI Logic firmware to it and it broke the BIOS (cannot do Ctrl+R) for booting purposes but allows other functionality to work normally. I tried downgrading to a Dell firmware for Perc 6i but it won't work, not even with MegaCli wget http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN --2013-08-26 12:53:39-- http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN Resolvi........
  • LSI MegaRAID Adventures, Guide and HowTo


    LSi Megaraid At first it was configured as a RAID 0, then I deleted the Virtual Disk Group. I thought both drives would be shown and detected in Linux as sda and sdb but it actually shows nothing. To make them work you have to hit Ctrl+R before the system boots (when prompted) and create a Virtual Disk Group. In my case I created each one as RAID 0 (with a single drive only) as I just wanted JBOD but there is no such option or default in these Dell Pe........
  • rpmforge Centos 6 x64 howto install


    rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt rpm -ivh http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm Retrieving http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm Preparing... ########################################### [100%] 1:rpmforge-release #############........
  • package kernel-xen-2.6.18-274.7.1.el5.x86_64 is intended for a x86_64 architecture solution


    package kernel-xen-2.6.18-274.7.1.el5.x86_64 is intended for a x86_64 architecture Linux etc 2.6.18-274.7.1.el5xen #1 SMP Thu Oct 20 17:06:34 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux As you can see above architecture and kernel is 64-bit but I had to force it to install using "--ignorearch" Solution #rpm --ignorearch -ivh kernel-xen-2.6.18-274.7.1.el5.x86_64.rpm Preparing...&nb........
  • Directadmin error/** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows: e2fsprogs-devel-1.41.12-3.el6.i686 has missing requires of e2fsprogs-libs = ('0', '1.41.12', '3.el6') e2fsprogs-devel-1.41.12-3.el6.i686 has missing requires of l


    Solution To The Following: yum -y install zlib-devel yum -y install e2fsprogs* *** Cannot find /usr/include/et/com_err.h. (yum install libcom_err-devel) *** Installation didn't pass, halting install. Once requirements are met, run the following to continue the install: cd /usr/local/directadmin/scripts ./install.sh Common pre-install commands: http://help.directadmin.com/it........
  • Centos 6 RTL8111/8168B r8169 link up and down error solution/fix


    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03) For whatever reason it seems the r8169 driver that ships and has shipped with most Linux distros for years is still flawed and does not work properly on these cards, causing 100mbit connectivity when it should be 1gbit and even worse, causing random network dropouts. The r8169 driver in Linux kernels is simply not meant to be used on th........
  • Centos 5 and OpenVZ won't boot after kernel install


    For whatever reason the current OpenVZ yum repo file enables the RHEL6 version of OpenVZ, why is this bad? Because if you're running Centos 5 it still defaults to using the kernel from RHEL6 which won't work on RHEL5/Centos 5. Ionly realized this after wondering why I couldn't boot into OpenVZ that it was using one meant for RHEL6. To fix the problem you have to edit /etc/yum.repos.d/openvz.repo and disable the "[openvz-kernel-rhel6]" section by changing........
  • Centos how to upgrade from PHP 5.2 to 5.3 without downtime


    This may sound silly but there will be conflicts/issues with the default Centos repository so you have to use a third party like remi (I prefer not to do this but it's the only option unless you migrate your sites/data to another server or can stand some downtime-not an option IMHOon a production server). You may need to upgrade to PHP5.3 to run Joomla or many other reasons. Your host needs to use PHP 5.2.4 or higher to run this version of Jo........
  • Centos Complete RPM/ISO Archive is at http://vault.centos.org


    This is so handy, especially if you need things like old kernels etc..., this is the main and practically only place you'll ever find what you need. http://vault.centos.org........
  • rpmforge: [#### ] 471/10722Segmentation fault yum[18934]: segfault at 0000000000000000 rip 00002ade62153a30 rsp 00007fff76f9fe58 error 4


    A few days ago this happened on multiple Centos 5 servers and apparently anyone using rpmforge was affected by this error and there was no solution other than disabling that repo to fix it. To some this highlighted a few points, that there is a reason RHELexists with full paid support, and also that this could be a vulnerability and huge flaw with yum. A yum search or install should not segfault just because the rpmforge repo goes down. Fortunately it came back up........
  • Openvz YUM Error Solution to "[Errno -1] Metadata file does not match checksum Trying other mirror."


    It's weird because I have a nearly identical box and setup and I can update the ovzkernel-PAE* just fine but on this box it doesn't work. I only get this error with the openvz.repo and not others such as Centos-Base.repo With my other server it works normally: ================ Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package ovzkernel-PAE.i686 0:2.6.18-238.12.1.el5.0........
  • Kernel/make compilation time and how to improve compile times/compile the Linux kernel faster without hardware upgrades


    I thought only a faster CPUand SSDwould help but I already have a Quad-Core CPU and it wasn't being maxed out. The actual tests were performed on an AMD-V enabled 128MB dual core VMWare container though. There is a flag that can be passed to make in order to start multiple threads, by specifying 4 threads I was able to reduce the whole kernel compilation time from scratch by about 50%! (65minutes vs 31minutes!). *Yes I did do a make clean before each co........
  • mysql enable slow query logging/Query Cache Solution - find/track cause of slow mysqld/high IO/CPU usage


    If you have a webserver and find you have high IO/lagginess MySQL is one of the first things to check. It turns out MySQL was my problem and it was creating a high load on my server, especially for IO. How to Enable MySQL Slow Query Logging To Find Slow Performance/Queries vi /etc/my.cnf Add this anywhere under [mysqld] #slow queries log-slow-queries = /var/log/mysql/mysqlslowqueries.log long_query_time = 1........
  • vnstat setup guide/tutorial


    yum -y install vnstat chown nobody.nobody -R /var/lib/vnstat/ #replace venet0 below with your desired interface sudo -u nobody vnstat -u -i venet0 #edit: vi /etc/sysconfig/vnstat #VNSTAT_OPTIONS="-i venet0" # only use the sed below if you are using venet0 instead of eth0 or replace accordingly sed -i 's/eth0/venet0/g' /etc/sysconfig/vnstat [root@monitor]# yum install vn........
  • 2011 Best Laptop - HP 15.6" Laptop featuring AMD Athlon II P340 Processor (G62-420CA)


    My mother needed a new laptop and I recommended her the same one I would have bought myself or my wife, that means the cheapest possible laptop with the most features for the money. This HP shines at this price point and one thing that made me stay away from buying more and recommending HP/Compaq was the poor battery life. Not anymore, this model has an industry leading up to 4 hours of battery life. Key Factors for Choosing It: HDMI Out........
  • Enable SPAMASSASSIN on Postfix in 5 minutes


    Centos 5 Postfix and SPAMASSASSIN Tutorial yum install spamassassin chkconfig spamassassin on vi /etc/mail/spamassassin/local.cf ############## #required_hits 5 #report_safe 0 #rewrite_header Subject [SPAM] #5 is the least restrictive (means only the most obvious SPAM is caught. 0 is obviously the most restrictive/sensitive and would have lots of false positives require........
  • Installing Webmin & Enabling SSL


    Webmin Setup Centos 5: wget http://downloads.sourceforge.net/project/webadmin/webmin/1.530/webmin-1.530-1.noarch.rpm?r=http%3A%2F%2Fwww.webmin.com%2Fstandard.html&ts=1294339690&use_mirror=surfnet [1] 24229 [2] 24230 [root@host ~]# --2011-01-06 21:48:20-- http://downloads.sourceforge.net/project/webadmin/webmin/1.530/webmin-1.530-1.noarch.rpm?r=http%3A%2F%2Fwww.webmin.com%2Fstandard.html Resolving downloads.sourceforge.net... 216.34.181.........
  • yum in Centos 5/Xen halts and exits suddenly


    yum exits in the middle The problem is this VPS seems to be an OpenVZ template from HyperVM. The only way to make it work was to disable i386 packages since this was an x64 kernel. That shouldn't be necessary but it was the only way to make yum stop quitting after the first package or two. I couldn't find any issue by checking the logs either. echo y|yum install vim-minimal telnet expect jwhois net-tools slocate iptables elinks gawk L........
  • yum error with some versions of Centos Refusing to automatically import keys when running unattended. Use "-y" to override.


    Refusing to automatically import keys when running unattended. Use "-y" to override. When using echo y|yum install gcc Fix with rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*........
  • http://apt.sw.be/redhat/el5/en/i386/test/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found Trying other mirror.


    http://apt.sw.be/redhat/el5/en/i386/test/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmforge-testing. Please verify its path and try again Notice it is complaining about "rpmforge-testing", just disable it for now: Solution is to edit the repo: vi /etc/yum.repos.d/rpmforge-testing.repo........
  • Openvz Quick Install for CentOS 5 Tutorial


    cd /etc/yum.repos.d wget http://download.openvz.org/openvz.repo rpm --import http://download.openvz.org/RPM-GPG-Key-OpenVZ yum install ovz-kernel-PAE Now remember to set /etc/sysctl.conf to "net.ipv4.ip_forward = 1" You can apply the change immediately by running sysctl -w net.ipv4.ip_forward = 1 but remember that you still have to set sysctl.conf sysctl -p will load and apply any changes to s........
  • Installing Virtualbox on Centos 5.5


    wget http://download.virtualbox.org/virtualbox/3.2.8/VirtualBox-3.2-3.2.8_64453_rhel5-1.i386.rpm rpm -i http://download.virtualbox.org/virtualbox/3.2.8/VirtualBox-3.2-3.2.8_64453_rhel5-1.i386.rpm error: Failed dependencies: libGLU.so.1 is needed by VirtualBox-3.2-3.2.8_64453_rhel5-1.i386 libSDL-1.2.so.0 is needed by VirtualBox-3.2-3.2.8_64453_rhel5-1.i386 libXmu.so.6 is needed b........
  • Picking an FTPD (vsftpd) Server in Linux Centos/Debian


    I decided on using yum to help me decide even though I normaly use proftpd I decided to see what else I could find. yum search ftp Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * rpmforge: ftp-stud.fht-esslingen.de * base: mirrors.netdna.com * updates: updates.interworx.info * addons: yum.singlehop.com * extras: mirrors.netdna.com rpmforge........
  • OpenVZ backup container to a single file while it's running using "vzdump"


    Proxmox has made this free utility to backup running OpenVZ containers. It's a great program which is actually just a PERL script but gets the job done. This program is not 100% required because all it really does is cp -a from your container's path as far as I know but it is still good to have uniformity to how you backup your containers. For RPM distros such as Centos/RHEL/Fedora etc.. download and install this: wget http://www.proxmox.com/cms_proxm........
  • PHP cannot access /usr/bin/openssl


    PHP cannot access /usr/bin/opensslI have verified the username that runs the process is able to access /usr/bin/openssl and it does exist but the PHP script is saying it doesn't exist: [code:1:1fd0f3abbe] if (!file_exists($OPENSSL)) { //echo "ERROR: OPENSSL $OPENSSL not foundn"; }[/code:1:1fd0f3abbe] I don't get itI can clearly see the contents of /usr/bin by using the PHP system fu........
  • How to extract files from RPM & SRPM files


    How to extract files from RPM & SRPM filesmkdir any_directory cd any_directory rpm2cpio /location/of/package.src.rpm | cpio -d -i This will extract all files, I find it especially useful if you want to manually compile the kernel source from the srpm........
  • Centos 4.3 x64 & VMWare Server Beta


    Centos 4.3 x64 & VMWare Server Beta[code:1:6d0b2c8c2f] The correct version of one or more libraries needed to run VMware Server may be missing. This is the output of ldd /usr/bin/vmware: linux-gate.so.1 => (0xffffe000) libm.so.6 => /lib/tls/libm.so.6 (0xf7fbd000) libdl.so.2 => /lib/libdl.so.2 (0xf7fb9000) libpthread.so.0 => /lib/tls/libpthread.so.0 (0xf7fa7000) libX11.so.6 => not f........
  • Updated to Version 3.8 and can't login


    Updated to Version 3.8 and can't loginSSHD accepts my password but then hangs at "Last login: Wed Sep 13 21:30:02 2006 from" This occurred during a yum update after upgrading my release, installing the new kernel and rebooting. I got kicked out of sshd after seeing the following during yum update: telnet 100 % done 85/476 tux 100 % done 86/476 ntsysv 100 % done 87/476 rpmdb-redhat 94 % done 88/476........
  • Need identd for port 113 ? Install authd


    Need identd for port 113 ? Install authdyum install authd Happy identing :)Actually it's not that simple. It installs as an "xinetd" service and is disabled and turned off by deafult. To enable it run: [code:1:8c94df8319] chkconfig --level 3 auth on service xinetd restart [/code:1:8c94df8319] This will set identd aka authd to start by default. service xinetd resta........
  • Updating yum repos for DAG /etc/yum.repos.d


    Updating yum repos for DAG /etc/yum.repos.dIn /etc/yum.repos.d [quote:96456b2ab9]Create any file such as "CentOS-Dag.repo" in /etc/yum.repos.d[/quote:96456b2ab9] Add the following to the above file: [code:1:96456b2ab9] [dag] name=Dag RPM Repository For Red Hat Enterprise Linux baseurl=http://dag.atrpms.net/redhat/el$releasever/en/$basearch/dag/ http://dag.freshrpms.net/redhat/e........
  • How to Track Down/Find Cause of Linux high disk iowait/wa


    top - 09:34:12 up 2 days, 20:57, 2 users, load average: 1.83, 1.99, 2.03 Tasks: 59 total, 2 running, 57 sleeping, 0 stopped, 0 zombie Cpu(s): 0.3%us, 0.0%sy, 0.0%ni, 0.0%id, 99.7%wa, 0.0%hi, 0.0%si, 0.0%st That 99.7% wa is iowait, it means the server is waiting for a process to complete an IOoperation or in plain English, there is a delay in........
  • How To Enable 3rd/third party packages in RHEL/Redhat/Centos 4/5 Linux via RPMForge


    It's a bit of a pain that many basic third party tools that aren't put of the main Centos/RHEL repositories are not available unless you compile them or install the RPMForge Repo. *Updated 08/29 with new download location changed from apt.sw.be to rpmforge.sw.be Here's a quick, simple/cut&paste way to do it: wget http://rpmforge.sw.be/redhat/el5/en/i386/rpmforge/RPMS/rpmforge-release-0.5.1-1.el5.rf.i386.rpm rpm -i rpmforge........
  • yum error not working rpmdb: mmap: No such device TypeError: rpmdb open failed


    Loaded plugins: fastestmirror rpmdb: mmap: No such device error: db4 error(19) from dbenv->open: No such device error: cannot open Packages index using db3 - No such device (19) error: cannot open Packages database in /var/lib/rpm Traceback (most recent call last): File "/usr/bin/yum", line 29, in ? yummain.user_main(sys.argv[1:], exit_code=True) File "/usr/share/yum-cli/yummain.py&qu........
  • sudo: Error dropping capabilities, aborting in Linux Centos 5.3


    For some reason Ikeep getting this error when trying to run a sudo command eg: sudo -u someuser somecommand sudo: Error dropping capabilities, aborting My version of sudo is:sudo-1.6.9p17-3.el5_3.1 and I've heard that version 1.7 fixes everything. The only thing is yum does not think sudo has any update. Iguess the new version has not been committed to the RPM repository yet. This is really a huge and ann........
  • Latest Articles

  • python 3 pip cannot install mysql module
  • QEMU-KVM won't boot Windows 2016 or 2019 server on an Intel Core i3
  • Virtualbox vbox not starting "No suitable module for running kernel found"
  • Bind / named not responding to queries solution
  • Linux Mint How To Set Desktop Background Image From Bash Prompt CLI
  • ImageMagick Convert PDF Not Authorized
  • ImageMagick Converted PDF to JPEG some files have a black background solution
  • Linux Mint Mate Customize the Lock screen messages and hide username and real name
  • Ubuntu/Gnome/Mint/Centos How To Take a partial screenshot
  • ssh how to verify your host key / avoid MIM attacks
  • Cisco IP Phone CP-8845 8800/8900 Series How To Reset To Factory Settings Instructions
  • ls how to list ONLY directories
  • How to encrypt your SSH private key file id_rsa
  • Linux Mint 18 Disable User Name List from showing on Login Screen
  • Firefox Cannot Hit Enter Key In Address Bar and Location History Not Working
  • Cisco Unified Communications Manager / CUCM IP 8.6,10,12 Install Error Solution
  • Ubuntu Debian Mint Linux SSHD OpenSSH Server Not Starting After Reboot Solution
  • nmap how to scan for all ports and not just the 1000 most common ports
  • Windows 7,8,10 and Server 2008, 2012, 2016, 2019 Read Only Attribute Won't Go Away
  • bind / named how to make a wildcard record and retain defined A records