• How To Boot Cisco CUCM UCSInstall 8.6, 10, 11 and 12 on KVM/Proxmox


    The key thing is that you must use a "machine"id of "pc-1.3" or it will say your hardware is not supported. Additionally you MUST use a virtio disk or you will get a ks_pre.sh error as soon as the install starts (a look at logs will show it can't find a disk). This is funny because even though the OS finds the disk and an fdisk -l shows it, it looks like the script looks for a /dev/vda device (virtio) and nothing else, so if you didn't use Virtio as you........
  • VMWare Pro Workstation Nic Disconnected and No IP Using NAT


    By default VMWare Workstation often doesn't work as we would like. If you create a VM with a default NAT IP it won't work you will find the NIC is disconnected (even though on the VMWare side it says connected including at Power On). How To Solve It 1.) Create New VMNet for NAT Click "Edit" -> "Virtual Network Editor" Click "Add Network" Select Network To Add "VMNet1" (........
  • vmkping -I vmk1 10.0.2.69 PING 10.0.2.69 (10.0.2.69): 56 data bytes sendto() failed (Host is down)


    [root@localhost:~] vmkping -I vmk1 10.0.2.69 PING 10.0.2.69 (10.0.2.69): 56 data bytes sendto() failed (Host is down) vsphere distributed switch vmotion not working [root@localhost:~] esxcfg-route -l VMkernel Routes: Network Netmask Gateway Interface&........
  • VMWare vSphere 6.7 Errors Solution 503 Service Unavailable (Failed to connect to endpoint:


    503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x00005556ba09c070] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe) 503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http16LocalServiceSpecE:0x00007fd26000b240] _serverNamespace = /ui action = Allow _port = 5090) Errors like the above are usually because there is an issue with your vSphere or more commonly it i........
  • VMWare ESXi 6.7 SSH/PowerShell CLI Commands


    [root@localhost:~] BootModuleConfig.sh echo host-ind nfcd........
  • VMWare Vsphere VCSA Graphical Install Creates json


    yes it does create its own json ============================================ cat /tmp/vcsaUiInstaller/ovftool-20180809-175238948-20180809-175603497.log |grep -i json 2018-08-09T17:56:04.238-07:00 verbose OVFTool[30966] [Originator@6876 sub=Default] Manifest file entry: SHA1(VMware-vCenter-Server-Appliance-6.7.0.12000-8832884_OVF10-file1.json) = 1deb658c724767697587d5909c4051c01813e6a1 --> ........
  • VMWare Hardware virtualization is selected and cannot be deselected due to selection of VBS Insufficient resources to satisfy configured failover level for vSphere HA.


    There is no such option as "VBS" that Ican see in vSphere 6.7 Ibelieve this is actually an issue because of using old hardware in this case L5420 doesn't support Nested Virtualization I believe. Hardware virtualization is selected and cannot be deselected due to selection of VBS Insufficient resources to satisfy configured failover level for vSphere HA.........
  • VSphere InternalServerError - Error When Adding Permissions


    InternalServerError (com.vmware.vapi.std.errors.internal_server_error) => { messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => { id = vapi.bindings.method.impl.unexpected, defaultMessage = Provider method implementation threw unexpected exception: com.vmware.vapi.std.errors.InternalServerError, args = [com.vmware.vapi.std.errors.InternalServerError] }], data = } I was getting the........
  • OVF Tool: Error: Task failed on server: This host does not support Intel VT-x. VMWare VCenter install On ESXi ERror


    Intel VT-X is enabled in Virtualbox but it doesn't seem to pass through the needed vmx extension despite the following variables on the host confirming it is enabled: cat /sys/module/kvm_intel/parameters/nested Y cat /sys/module/kvm_intel/parameters/ept Y OVF Tool: Disk progress: 99% OVF Tool: Transfer Completed OVF Tool: Powering on VM: Embedded-vCenter-Server-Appliance- OVF Tool: Task p........
  • Relocating modules and starting up the kernel - VMWare ESXi 6.7 Error and Solution


    I had this error in an unsupported CPUon VMWare 6.7 and apparently this sometimes works especially on older VMWare versions like 6.5 5.5 etc (but in my case it did not). To make sure it proceed when you see "Loading VMWare" Hit "Shift+O" Then add "ignoreHeadless=TRUE" See an example below:........
  • VMWare 6.7 VCSA VSphere ESXi Management SSO Install Guide on Linux using the CLI


    #mount the VCSA DVD mount /dev/sr0 /mnt/cd #alternatively you could mount the iso directly mount -o loop vcsa.iso /your/mount/path #for this purpose we are using the CLI installer on Linux cd /mnt/cd/vcsa-cli-installer/lin64 #no it's not going to be that easy you can't just run vcsa-deploy like that you need to use a template or configured .json file ./vcsa-deploy Usage: vcsa-deploy [-h] [--version] [--supported-deploymen........
  • Windows 2012 Server R2 Install Error "windows cannot find the microsoft license terms windows 2012 server install"


    windows cannot find the microsoft license terms windows 2012 server install This is actually because you are using less than 576MB of RAM. In my case I was installing on a KVM VPS with 512MB of RAM. This issue would apply to any physical or virtual server with less than 576MB of RAM. This includes Virtualized VPS Servers with XENHVM, KVM, VBOX, VMWare etc.. or Dedicated Servers with such little RAM. It's very misleading of course since it has not........
  • LSI MegaRAID Adventures, Guide and HowTo


    LSi Megaraid At first it was configured as a RAID 0, then I deleted the Virtual Disk Group. I thought both drives would be shown and detected in Linux as sda and sdb but it actually shows nothing. To make them work you have to hit Ctrl+R before the system boots (when prompted) and create a Virtual Disk Group. In my case I created each one as RAID 0 (with a single drive only) as I just wanted JBOD but there is no such option or default in these Dell Pe........
  • How to convert raw,img,vdi,vmdk and other virtual image formats using qemu-img convert between VBOX/KVM/VMWare/Xen


    The example below converts youvm.img into a vdi. The -O vdi specifies the new format will be vdi but you can use any other valid formats/vice versa. qemu-img convert yourvm.img -O vdi yourvm.vdi This is very handy for those who need to switch between virtualization technologies.........
  • vmware Failed to initialize monitor device 95% power on


    Failed to initialize monitor device 95% power on Solution /etc/init.d/vmware-core start........
  • Kernel/make compilation time and how to improve compile times/compile the Linux kernel faster without hardware upgrades


    I thought only a faster CPUand SSDwould help but I already have a Quad-Core CPU and it wasn't being maxed out. The actual tests were performed on an AMD-V enabled 128MB dual core VMWare container though. There is a flag that can be passed to make in order to start multiple threads, by specifying 4 threads I was able to reduce the whole kernel compilation time from scratch by about 50%! (65minutes vs 31minutes!). *Yes I did do a make clean before each co........
  • Virtualbox How To Clone VM/Container VDI file


    You can't just do a straight copy of the VDI image of your virtual machine because there is a unique UUID, wellI believe you can and then you can create a new UUID manually (at least you could with VMWARE) but to keep it clean just use this method: VBoxManage clonevdi /path/to/your.vdi outputname.vdi 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100% That's all there is to it, just wait for it copy and you can th........
  • VMWare bridged adapter not working: The network bridge on device vmnet0 is not running. The virtual machine will not be able to communicate with the host or with other machines on your network. Failed to connect virtual device Ethernet1.


    VMWare bridged adapter not working: Message from system: The network bridge on device vmnet0 is not running. The virtual machine will not be able to communicate with the host or with other machines on your network. Failed to connect virtual device Ethernet1. I'm not sure how to fix this but one of the issues is that my eth0 became eth1 after moving my hard drives to a new motherboard. I have run the vmware-config.pl but this did not resolve the issue.........
  • SSH delay problem UseDNS and disabling GSSAPI does not help


    The normal solution doesn't help or apply here: ssh -v user@192.168.5.41 OpenSSH_4.3p2 Debian-9etch3, OpenSSL 0.9.8c 05 Sep 2006 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug1: Connecting to 192.168.5.41 [192.168.5.41] port 22. debug1: Connection established. debug1: permanently_set_uid: 0/0 debug1: identity file /root/.ssh/identity type -1 debug1: i........
  • vmare server - Cannot open the disk '/mnt/sda4/vmware/Debian/hdd.vmdk' or one of the snapshot disks it depends on. Reason: Failed to lock the file.


    Go into the directory for your Virtual Machine and delete all ".lck" directories. rm -rf *.lck After that your server should boot.........
  • VMWare Server cannot connect to web interface SSL Handshake on client connection failed: SSL Exception


    VMWare log: /var/log/vmware/hostd.log SSL Handshake on client connection failed: SSL Exception sudo /etc/init.d/vmware-mgmt restart Stopping VMware management services: VMware Virtual Infrastructure Web Access VMware Server Host Agent&nb........
  • VMWare Server is on SSL port 8333


    I'm mentioning this because I keep forgetting what port the management is on for the web interface (since newer releases of VMWare server took away the superior stand alone client). So remember it is port 8333 and sometimes you need to restart vmware-mgmt service and also enable sslv2 in your Firefox or it won't connect.........
  • VirtualBox Convert Import/Boot .vmdk VMWare Hard Disk/Drive Image Won't Work


    I wanted to Import/Use a .vmdk hard disk image file from VMWare. Generally you can just "point" VirtualBox to it and use it and it will work but I found an exception. One of my Centos 4.4 x64 images wouldn't boot. I had two copies, an older one and the newer one. The older one booted as normal (once I changed the VirtualBox driver to IDE from SATA). The newer one stopped at the "GRUB loading" message no matter what I tried. As far as........
  • Install Mac OS X 10.4.6 Tiger on AMD32 VMWare


    *Note OS X is strange to install, I thought my HDD was not being detected by you just have to go to Diskutil and create a partition for the root filesystem and then close/move the Window and proceed with the install. After install Mac OS X 10.4.6 Tiger I get a black screen that says: b0 error Most people say the partition has to be marked as "active", actually that just means marked as "bootable". Instead of t........
  • Convert HDD/Hard Drive Partition(s) into non-RAID into RAID 1 using existing data without data loss and without reformatting.


    Before we start I take no responsibility for this, you should have a backup and if you make a mistake during this process you could wipe out all of your data. So backup somewhere else before starting this as a precaution, or make sure it's data you could afford to lose. The RAID 1 Setup (Hardware Wise) I've already setup my 2 x 1TB (Seagate) drives with identical partitions, make sure your new hard drive (the empty one) is setup like your curr........
  • Linux EXT3 16GB-17GB maximum filesize issue solved/how to fix


    I have no idea why but mkfs.ext3 defaults to a patheticlly small blocksize of 1024 bytes/1KB (kilobyte). That means the maximum filesize is ONLY 16GB! With 2KB/2048 bytes you get a 256 GB maximum filesize, and with 4KB/4096 bytes you get 2TB! I finally noticed/paid attention to this after realizing that with rsync and scp that no file larger than 17GB could be transferred. I then realized it must be a file size limit on the partition. Here is what tune2fs tol........
  • Rsync Timeout/Stall On Large files bigger than 16GB/Cannot Transfer large files with rysnc


    The last transfer I was able to do was 16.77GB according to rsync's output and it worked fine. 16.77G 100% 10.66MB/s 0:25:00 (xfer#17484, to-check=234753/256249) But on a file over 17GB (gigs) it stalls. Trust me, it really is stalled, it's been about 8 hours with no progression from that point for some reason. 17.24G 54% 10.65MB/s 0:22:07........
  • Centos 4.3 x64 & VMWare Server Beta


    Centos 4.3 x64 & VMWare Server Beta[code:1:6d0b2c8c2f] The correct version of one or more libraries needed to run VMware Server may be missing. This is the output of ldd /usr/bin/vmware: linux-gate.so.1 => (0xffffe000) libm.so.6 => /lib/tls/libm.so.6 (0xf7fbd000) libdl.so.2 => /lib/libdl.so.2 (0xf7fb9000) libpthread.so.0 => /lib/tls/libpthread.so.0 (0xf7fa7000) libX11.so.6 => not f........
  • Updated to Version 3.8 and can't login


    Updated to Version 3.8 and can't loginSSHD accepts my password but then hangs at "Last login: Wed Sep 13 21:30:02 2006 from" This occurred during a yum update after upgrading my release, installing the new kernel and rebooting. I got kicked out of sshd after seeing the following during yum update: telnet 100 % done 85/476 tux 100 % done 86/476 ntsysv 100 % done 87/476 rpmdb-redhat 94 % done 88/476........
  • Clustered/Distributed Network Filesystems, Which Ones live up to the hype?


    I've tried to find a good sensible solution to cluster with and each technology has it's pros and cons and there is no perfect solution and I've found a lot of "exaggerations" in the applications, benefits and performance of these different filesystems. DRBD I first started off with DRBD and Ihave to say it does live up to the hype, is quite reliable (although it can be annoying to match up the kernel module and user applications since they must match and whe........
  • SIOCSIFADDR No such device eth0 error while getting interface flags - eth0 Ethernet Device can


    Igot this after copying a VMWare image onto another machine in Debian. SIOCSIFADDR No such device eth0 error while getting interface flags The solution 1.) Find and edit the device line in persisent-net.rules note it will be prefixed with something like z25 or something else. vi /etc/udev/rules.d/z25_persistent-net.rules The easiest way is to comment anything out. If you are feeling........
  • OCFS2 crash


    When trying to even cd or ls the mounted OCFS2 partition it crashes. Ithink this is a combination of VMWare Server's problem and the way I mounted and symlinked to it. More than anything this shows the problem and lack of forsight with VMWare, but also that OCFS2 is easily crashed if you do strange things. Output of /var/log/messages for OCFS2 Apr 10 15:57:45 localhost kernel: [84331.691258] Modules linked in: vmnet vmci vmmon ocfs2_stac........
  • Latest Articles

  • Cisco Switches How To Get Of Port Line Status Console Messages
  • Cisco DHCP Snooping Relay Setup Information
  • Cisco Switch Setup Guide Command List
  • Cisco 2960 Switch Reset To Factory Defaults
  • How To Boot Cisco CUCM UCSInstall 8.6, 10, 11 and 12 on KVM/Proxmox
  • VBOX VirtualBox How To Import Raw .img Disk File
  • Windows Server 2012, 2016, 2019 How To Install and Missing Disabled Telnet Client
  • proxmox vm networking breaks when you restart your network on the hostnode
  • Linux ln symlink how to update existing symbolic link
  • Ubuntu 18.04 / Linux Mint 19.1 Cannot Type or Login - solution
  • LUKS Hard Drive Encryption on Linux Mint Ubuntu Debian etc how to mount encrypted hard drive
  • How to use nmap locate other machines/computers/servers on your network using nmap
  • Linux Mint 18.2 Create Config File To Start Application Upon Login
  • Dell Wyse Thin Client BIOS Access Key
  • sudoers file in /etc warning about comments/includes!
  • Centos 7 Reallocate logical volume space to another
  • lvm how to reduce volume size
  • letsencrypt certbot error "Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80."
  • SSH error cannot Forward or Listen "bind: Cannot assign requested address"
  • X11 SSH Linux Forwarding Error