yum Packages skipped because of dependency problems:

Solution:

yum -y install --skip-broken package-you-want-to-install

Packages skipped because of dependency problems:
    php56w-mysql-5.6.30-1.w6.x86_64 from webtatic
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
      
         1. You have an upgrade for apr which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of apr of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude apr.otherarch ... this should give you an error
            message showing the root cause of the problem.
      
         2. You have multiple architectures of apr installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
      
         3. You have duplicate versions of apr installed already.
            You can use "yum check" to get yum show these errors.
      
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
      
       Protected multilib versions: apr-1.3.9-5.el6_2.i686 != apr-1.5.2-2.x86_64
Error: Protected multilib versions: apr-util-1.3.9-3.el6_0.1.i686 != apr-util-1.5.4-2.x86_64


Tags:

yum, packages, skipped, dependency, install, php, mysql, _, webtatic, multilib, eg, upgrade, apr, requires, installing, architecture, exclude, redoing, otherarch, multiple, architectures, installed, arcitectures, update, duplicate, versions, quot, errors, setopt, protected_multilib, util,

Latest Articles

  • Huion and Wacom Tablets How To Install in Linux Mint / Ubuntu and make the stylus work properly
  • ffmpeg how to cut certain parts of video out
  • ffmpeg how to concat and join two video clips
  • mencoder instead of ffmpeg to join or concatenate video files with different audio streams
  • Linux How To Stop Missing Drive from Halting Boot Process in fstab
  • How To Replace Audio Track of Video using ffmpeg
  • qemu-img convert formats vdi vmdk raw qcow2
  • Linux and Windows Dual Boot Crazy Time Issues
  • dynagen / dynamips 100% high CPU usage solution - how to set the idlepc value
  • How To Setup a Cisco CME (Cisco Manager Express) Virtual Router under Linux using dynamips and dynagen
  • Linux Mint Ubuntu Debian CentOS Dual Boot Install Issues
  • Linux Mint Ubuntu Debian Centos RHEL no sound solution
  • Linux Mint/Debian/Ubuntu/Centos Installer black grub screen and blank screen after trying to boot installer or main OS
  • Linux Mint Dual Boot Install Avoid Wiping our your Main C: drive /dev/sda MBR and EFI
  • QEMU-KVM soundhw deprecated how to enable sound in QEMU 4.x series
  • Virtualbox Error Cannot register the hard disk because a hard disk with UUID already exists solution
  • kernel: [549267.368859] mate-terminal[7871]: segfault at 2000000101 ip 00007f5d0a9548f0 sp 00007fff7012c610 error 4 in libgobject-2.0.so.0.4800.2[7f5d0a920000+52000]
  • apcupsd how to setup and monitor APC UPS units
  • How To Password Reset, Recover, Bypass, Remove and Unlock on Windows 10,8,7,Vista,XP,NT,2000,2003,2008,2012,2016,2019 Administrative Login Programs
  • Nvidia Ubuntu Linux Screentearing Video with solution driver