SMF Forums / Simple Machines Forums Not Displaying Images Theme or Styles Properly using 127.0.0.1

This is one thing that has me wondering about SMF. It is apparently a known issue but in the latest version and new install nothing looked right because it was using http://127.0.0.1 to find everything! How on earth would it ever do this or think it is normal?

Excerpt of crazy html code it produces that causes the issue:











To repair it you need to get a tool from the SMF site: https://wiki.simplemachines.org/smf/Repair_settings.php#Download_the_Repair_Settings_Tool

Get the tool run it and you'll see some output like this:

Almost always aside from MySQL DB you should change 127.0.0.1 to the domain name of your server.



URLs
These are the paths and URLs to your SMF installation, and can cause big problems when they are wrong. Sorry, there are a lot of them.
Forum URL:
Recommended value: "https://forums.domain.com".
Forum Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs".
Sources Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs/Sources".
Attachment Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs/attachments".
Avatar URL:
Recommended value: "https://forums.domain.com/avatars".
Avatar Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs/avatars".
Custom Avatar URL:
Value not found!
Custom Avatar Directory:
Value not found!
Smileys URL:
Recommended value: "https://forums.domain.com/Smileys".
Smileys Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs/Smileys".






Paths & URLs For Themes
These are the paths and URLs to your SMF themes.
SMF Default Theme - Curve URL:
Recommended value: "https://forums.domain.com/Themes/default".
SMF Default Theme - Curve Images URL:
Recommended value: "https://forums.domain.com/Themes/default/images".
SMF Default Theme - Curve Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs/Themes/default".
Core Theme URL:
Recommended value: "https://forums.domain.com/Themes/core".
Core Theme Images URL:
Recommended value: "https://forums.domain.com/Themes/core/images".
Core Theme Directory:
Recommended value: "/var/www/vhosts/domain.com/httpdocs/Themes/core".


Tags:

smf, forums, displaying, images, styles, install, http, excerpt, html, produces, rel, quot, stylesheet, text, css, href, themes, default, index, fin, javascript, src, scripts, js, img, upshrink, png, alt, expand, header, display, smflogo, forum, div, repair, https, wiki, simplemachines, org, repair_settings, php, download_the_repair_settings_tool, ll, output, mysql, db, domain, server, urls, paths, installation, url, recommended, directory, var, www, vhosts, httpdocs, sources, attachment, attachments, avatars, custom, smileys,

Latest Articles

  • Microsoft Teams Linux - Calendar Doesn't Work Missed Meetings!
  • Scanner not working in Linux Ubuntu Fedora Mint Debian over the network? Use sane-airscan!
  • How To Boot, Install and Run Windows 2000 on QEMU-KVM
  • bash cannot execute permission denied
  • Huion and Wacom Tablets How To Install in Linux Mint / Ubuntu and make the stylus work properly
  • ffmpeg how to cut certain parts of video out
  • ffmpeg how to concat and join two video clips
  • mencoder instead of ffmpeg to join or concatenate video files with different audio streams
  • Linux How To Stop Missing Drive from Halting Boot Process in fstab
  • How To Replace Audio Track of Video using ffmpeg
  • qemu-img convert formats vdi vmdk raw qcow2
  • Linux and Windows Dual Boot Crazy Time Issues
  • dynagen / dynamips 100% high CPU usage solution - how to set the idlepc value
  • How To Setup a Cisco CME (Cisco Manager Express) Virtual Router under Linux using dynamips and dynagen
  • Linux Mint Ubuntu Debian CentOS Dual Boot Install Issues
  • Linux Mint Ubuntu Debian Centos RHEL no sound solution
  • Linux Mint/Debian/Ubuntu/Centos Installer black grub screen and blank screen after trying to boot installer or main OS
  • Linux Mint Dual Boot Install Avoid Wiping our your Main C: drive /dev/sda MBR and EFI
  • QEMU-KVM soundhw deprecated how to enable sound in QEMU 4.x series
  • Virtualbox Error Cannot register the hard disk because a hard disk with UUID already exists solution