/ - rtt - IT Resource

  • How to download gajim 0.16.9 XMPP/Jabber client so you can use OMEMO encryption


    #Linux Mint 18.2 how to install gajim .16.9 so you can use OMEMO encryption: sudo apt-get install python-axolotl python-nbxmpp wget https://gajim.org/downloads/0.16/gajim-0.16.9.tar.gz tar -zxvf gajim-0.16.9.tar.gz cd gajim-0.16.9 ./autogen.sh ;make;sudo make install #if you get this error you need to get a newer python-nbxmpp from here: gajim Gajim needs python-nbxmpp >= 0.6.1 to run. Quiting...........
  • SMF Forums / Simple Machines Forums Not Displaying Images Theme or Styles Properly using 127.0.0.1


    This is one thing that has me wondering about SMF.  It is apparently a known issue but in the latest version and new install nothing looked right because it was using http://127.0.0.1 to find everything!  How on earth would it ever do this or think it is normal? Excerpt of crazy html code it produces that causes the issue:     <link rel="stylesheet" type="text/css&qu........
  • Install Windows From a Linux TFTP Server instead of using WDS Solution


    yum -y install samba vi /etc/samba/smb.conf https://www.kernel.org/pub/linux/utils/boot/syslinux/syslinux-6.03.zip mkdir syslinux;cd syslinux;unzip syslinux-6.03.zip mkdir -p /tftpboot/libs/ cp bios/com32/modules/linux.c32 /tftpboot/libs/ cp bios/com32/libutil/libutil.c32 /tftpboot/libs/ cp bios/com32/lib/libcom32.c32 /tftpboot/libs/ #add lib path echo "PATH libs" >> /tftpboot/pxeli........
  • Nvidia Linux Mint/Ubuntu screentearing horizontal line solution


    Finally after ages I found the solution which is on many pages on the net but not obvious and should have been standard or more common info! Instant Solution: Type this into the terminal (unfortunately the driver config menu doesn't have the option as itis hidden): nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline = On }" Make permanent   Cli........
  • Linux Mint missing ffmpeg solution to install from Ubuntu PPA


    This is very annoying that ffmpeg is missing from Linux Mint!  They have ffmpeg2theora which is a totally different codec and does not work as ffmpeg does at all (it is basically totally different). However on Linux Mint 17 I was able to use a Ubuntu PPA and sucessfully install ffmpeg! https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media Adding this PPA to your system........
  • Centos/obfsproxy errors


    I never did get it working, it is too bad as obfsproxy should really be an option and integrated into the OpenVPN client and server or something similar:   yum -y install python-pip python-devel No package python-pip available. #install the EPEL repo python-pip install obfsproxy python-pip install obfsproxy -bash: python-pip: command not found pip install obfsproxy    &........
  • Debian sources.list examples


    Based on this from Debian The 'distribution' can be either the release code name / alias (wheezy, jessie, stretch, sid) or the release class (........
  • How to root and unlock S4 in Canada Bell/Rogers/Telus/Fido I337 4.4.2


    <p>i337 Canada on Bell is hard to root or even install TWRP<br /> <br /> Installed TWRP from Odin and my computer gave me the bluescreen at the end but it seemed to be successful (after ODIN said reset).<br /> TWRP mode does not seem to enter, instead you get the Android recovery mode with Volume up + Home<br /> <br /> <br /> http://galaxys4root.com/galaxy-s4-root/how-to-root-att-or-verizon-galaxy-s4-on-android-4-4-2/<br /> <br /> 1.)........
  • How to update Open Office in Ubuntu/Debian if your repository is outdated or no longer supported


    http://sourceforge.net/projects/apacheoo-deb/files/debian/dists/wheezy/main/binary-i386/ To install AOO on your computer, you need to add the following entry to the /etc/apt/sources.list file: deb http://downloads.sourceforge.net/project/apacheoo-deb/debian wheezy main sudo apt-get update && sudo apt-get install openoffice-en* openoffice-brand-writer openoffice-brand-calc openoffice-brand-impress openoffice-brand-base open........
  • Ubuntu Download Packages/Updates for EOL Unsupported Old Releases


    I installed Ubuntu 11.04 for testing purposes but I couldn't even download SSH server: sudo sed -i -e 's/us.archive.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list After running the above make sure you do a "apt-get update" Note with the above that I have the search string of "us.archive.ubuntu.com" change it to whatever is in your sources.list The above does not fix all repositories either, I haven't  had a chance t........
  • FBDIMM /PC5300F RAM chips can work properly be with mixed timing/speeds


    I've read some people/sources say "the timing must match or it won't work".  This is not true at least for the Supermicro boards I've tested this on. Some examples: PC2-5300F-555-12 PC2-5300F-555-11 etc.. Notice the "12" and "11" Also the ones that have a "PC2-5300F-555-11-B0" or "PC2-5300-555-11-D0" are also fine. What happens is what one would expect, the........
  • Virtualmin/Webmin Postfix Error: The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active ..


    Virtualmin Postfix Error: The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active ..       A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration .. your system is not ready for use by Virtualmin. <- Solution  ........
  • EOL for Kubuntu/Ubuntu 8.04 - W: Failed to fetch http://ca.archive.ubuntu.com/ubuntu/dists/intrepid/universe/source/Sources.gz 404 Not Found [IP: 91.189.92.171 80]


    I couldn't figure out why I couldn't install a simple package.  This is what's annoying about cutting edge Debian distros, yes we know you support each license on average for 1-2 years but why take down the supporting binary packages and basically disable the older versions? sudo apt-get install update Reading package lists... Done Building dependency tree       Reading state information... Done E: Couldn't find p........
  • Installing Virtualbox on Centos 5.5


    wget http://download.virtualbox.org/virtualbox/3.2.8/VirtualBox-3.2-3.2.8_64453_rhel5-1.i386.rpm rpm -i http://download.virtualbox.org/virtualbox/3.2.8/VirtualBox-3.2-3.2.8_64453_rhel5-1.i386.rpm error: Failed dependencies:     libGLU.so.1 is needed by VirtualBox-3.2-3.2.8_64453_rhel5-1.i386     libSDL-1.2.so.0 is needed by VirtualBox-3.2-3.2.8_64453_rhel5-1.i386     libXmu.so.6 is needed b........
  • Picking an FTPD (vsftpd) Server in Linux Centos/Debian


    I decided on using yum to help me decide even though I normaly use proftpd I decided to see what else I could find. yum search ftp Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile  * rpmforge: ftp-stud.fht-esslingen.de  * base: mirrors.netdna.com  * updates: updates.interworx.info  * addons: yum.singlehop.com  * extras: mirrors.netdna.com rpmforge   ........
  • Fix/Solution for apt-get error: " E: Archive directory /var/cache/apt/archives/partial is missing."


    I thought I was being smart, I wanted to download some Debian packages so I went to /var/cache/apt/archives and did "rm -rf *" but then I couldn't use apt-get anymore.  I kept getting this error: E: Archive directory /var/cache/apt/archives/partial is missing. E: The list of sources could not be read. The solution was to recreate the "partial" directory inside /var/cache/apt/archives and then everything will be fine.........
  • Intrusion Detection Resources


    Intrusion Detection ResourcesI think this could be very useful even for home users in learning how to secure their networks or even offices. http://www.sans.org/resources/idfaq/........
  • Other Security Web Sites


    Other Security Web SitesSeveral websites actively track security issues. This list provides you with the major providers of security information on the Web. Many of these organizations also provide newsletters and mailings to announce changes or security threats: Center for Education and Research in Information Assurance and Security (CERIAS) CERIAS is an industry-sponsored center at Purdue University that is focused on technology and relate........
  • sudo: Error dropping capabilities, aborting in Linux Centos 5.3


    For some reason I keep getting this error when trying to run a sudo command eg: sudo -u someuser somecommand sudo: Error dropping capabilities, aborting My version of sudo is: sudo-1.6.9p17-3.el5_3.1 and I've heard that version 1.7 fixes everything.  The only thing is yum does not think sudo has any update.  I guess the new version has not been committed to the RPM repository yet. This is really a huge and ann........
  • iPhone Create Silent/Free Custom Ringtone jailbroken/jailbreak iPhone


    As shown below you can find ringtones in the "/private/var/stash/Ringones*" directory of your iPhone. Different reports have said that the .m4r format is really an MP4 file and some have said AAC and some also say "it's the same as the M4A" format.  Whatever the case is, one easy way is to install the silent theme from Cydia and copy that into your ringtones directory.   /private/var/stash/Ringtones.sh7cLj root# ls Alarm.m4r ........
  • How to unlock your iPhone 3G/3GS


    First of all you need to be jailbroken, but this is not covered here. Go into Cydia and click "Manage Sources" then "Edit" and add: repo666.ultrasn0w.com Then search for "ultrasn0w" as a package and install it, that's all there is to it, your iPhone is finally unlocked so when you travel abroad you can avoid ridiculous roaming charges, or you can switch providers and use any SIM card you like. You'd really thi........
  • iPhone/iTunes sync error "0xE8008001"


    This happened during a sync of my iPhone while installing some apps.  This usually happens to non-jailbroken iPhones who are trying to install non-Apple approved software OR jailbroken phones who haven't done the "Sync update". How to fix this error and get the Sync Update Open Cydia - Manage - Sources - Edit Add this source: http://cydia.hackulo.us Then under the section "Hackulo.us" install "Ap........
  • Latest Articles

  • syntax error, unexpected T_SL in PHP Solution
  • grep regular expression match number range between specific numbers
  • bash how to print out lines of text within a range from the first occurrence
  • bash script how to to check LAN computers for open ports
  • MySQL Using mytop Debug Source of High IO and Slow Performance
  • How To Mathematically Convert and Calculate Binary Value To Decimal Value
  • systemd management using systemctl and journalctl to check systemd logs
  • css how to format code in the code tag
  • css br with extra blank line
  • What is /dev/pts and why do we need it in Linux?
  • Linux What is umask (user mask) for file and directory creation permissions and how to calculate umask and change the defaults
  • Linux Permissions and Groups Real Usecase for Group Access
  • Centos 7 python34 how to install the gi library
  • Centos 7 - Convert Minimal to Graphical GUI GNOME or KDE Desktop
  • AMD Set Fan Speed and Other Powerplay Memory/CPU Timings with a Linux script
  • Ethereum Mining Claymore Nanopool Error
  • genisoimage errors with long filenames and deep directory structures
  • Linux Kernel USB Export Errors
  • How to download gajim 0.16.9 XMPP/Jabber client so you can use OMEMO encryption
  • HP DL385 G7 Linux BIOS Update Flash