• Linux partprobe/partx cannot access last and 4th partition


    On a test machine Iwas never able to access to a newly created 4th partiton. As we can see there are dev devices for everything but the 4th partition. The normal "partprobe" or "kpartx" or kernel being told to rescan the block device didn't help (only a reboot did). fdisk -l /dev/sda Disk /dev/sda: 750.2 GB, 750156374016 bytes 255 heads, 63 sectors/track, 91201 cylinders Units........
  • How To Enable Nested KVM so guests can virtualize with hardware extensions


    #check if nested KVM is enabled by doing a cat on nested inside sys root@s14:~# cat /sys/module/kvm_intel/parameters/nested root@s14:~# echo "options kvm-intel nested=Y" > /etc/modprobe.d/kvm-intel.conf root@s14:~# echo "options kvm-amd nested=1" > /etc/modprobe.d/kvm-amd.conf root@s14:~# modprobe -r kvm_intel modprobe: FATAL: Module kvm_intel is in use. root@s14:~# modprob........
  • VMWare ESXi 6.7 SSH/PowerShell CLI Commands


    [root@localhost:~] BootModuleConfig.sh echo host-ind nfcd........
  • Linux Mint Black Screen after boot no graphics solution


    This is not the normal "black screen"issue and I was shocked to eventually find out why. The normal advice of reconfiguring Xorg didn't work. Even booting into "Recovery Mode" did not help. Here is the short end of the stick that fixed it: sudo apt-get install mdm mate-desktop-environment Yes you got it right, mdm and the mate-desktop-environment / gnome were somehow uninstalled. This must be whe........
  • Linux Mint Ubuntu Debian How To Disable Webcam Automatically Onboot To Prevent Spying and Privacy Violations


    It is well known hackers, the NSA, CIA and other groups have created malware to secretly turn on your webcam and microphone on your phone, tv etc.. But fortunately on our computers and laptops we have some options. Most webcams use the "uvcvideo" kernel module / driver. You can disable this in two ways on boot. I recommend both just as a failsafe. Disable it on rc.local once your system boots automatically Add the followi........
  • pcimodules and lspci not working alternative solution


    pcimodules no longer works it produces nothing probably because the format of /sys/bus/pci is different. lspci -k doesn't work on older lspci versions. pciutils can be compiled but it won't work if you have an old system and compile on a newer glibc. iteriate through /sys/bus/pci/devices/*/modalias cat /sys/bus/pci/devices/*/modalias pci:v00008086d00001237sv00000000sd00000000bc06sc00i00 pci:v00008086d00007000sv0000000........
  • ffmpeg Linux Mint download, compile and install howto


    #if you have nvidia make sure you install the nvidia-cuda-toolkit so hardware acceleration can be used wget http://ffmpeg.org/releases/ffmpeg-3.3.2.tar.bz2 tar -jxvf ffmpeg-3.3.2.tar.bz2 cd ffmpeg-3.3.2/ ./configure --disable-yasm install prefix /usr/local source path ........
  • USB 3.0 External HDD Enclosure Seagate UAS problems - [sdd] tag#1 CDB: Write(16) 8a 00 00 00 00 01 70 04 08 68 00 00 00 08 00 00


    This is a 8TB Seagate external USB 3.0 device apparently newer kernels use a module called "UAS" instead of "USB Storage" which causes issues as a lot of devices are not properly supported in UAS mode by the kernel driver. The solution some say is to disable UAS specifically for your USB device but I'd rather just disable UAS altogether. Solution blacklist UAS: *do not do this it does not work and just causes your USB 3.0........
  • mcp55 NIC not working at boot on Centos 6.6-6.8


    forcedeth 0000:00:08.0: irq 25 for MSI/MSI-X forcedeth 0000:00:08.0: eth0: MSI enabled forcedeth 0000:00:08.0: eth0: no link during initialization ADDRCONF(NETDEV_UP): eth0: link is not ready forcedeth 0000:00:08.0: eth0: link up ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready Dec 1 18:21:32 box15 kernel: forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64. Dec 1 18:21:32 box15 kernel........
  • forcedeth MCP55 Nforce3600 Nvidia Network NIC Card Not working in Linux at 1gigabit speeds


    Now many people report this card simply not working in various Linux distros and kernels. My issue is different, it always works at 100mbit (eg. plugged into a 100mbit switch) but no matter what 1000M/gigabit switch I would try, it would never work. The link would be up (the lights were on) and the OS detected the link as being up as well but it wouldn't work at all and could not pass data in or out (not even a ack/ping). There is one simple solution and command........
  • Linux How To Recover Partition Table from Kernel and Restore Centos/Debian etc..


    We've all done this at some point, you work on the wrong shell window and this was my first time making this mistake but I deleted a partition table in fdisk, recreated it and saved it with "wq" and even ran partprobe! If you haven't rebooted yet then you can still recover your partition table, otherwise you're in big trouble. Fortunately since it was a live system and in use the kernel still had to use the old table like below:........
  • Nvidia Linux Card not working due to LSI 9200/SAS2008 IRQ conflict


    At first my BIOS said the card may not work right because there is no more option ROM space. I disabled the Option ROM for both LSI 1068 and 2008 chipsets, Network Boot ROM and most other PCI slots, Serial Port, etc... and the message went away but the card still does not work properly. But it still cannot initialize the card properly(does not work): [ 33.943272] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:........
  • mdadm real example of recovery and rebuilding of the array on Centos 6


    In this example we have 2 drives in a RAID array and /dev/sdb is the one that failed. /dev/sda1 is also the /boot partition which we tell grub to install on /dev/sdb eg install root (hd0,0) /dev/sda1 on the new drive /dev/sdb (hd1) First copy the partition table from /dev/sda to /dev/sdb dd if=/dev/sda of=/dev/sdb bs=512 count=1 Run partprobe to detect the new partition table partprobe........
  • Virtualbox errors on Ubuntu/Debian/Mint


    The solution was to reinstall the vbox dkms package and do a manual modprobe of the modules it makes. I never sorted out the unable to start due to the USB issue, I did have the guest additions installed but the only way to boot was to change the pointing device from USB to PS2 and then to disable the USB controller (if your pointing device is set as USB, disabling USB will not work because it will re-enable by default when it sees your pointing device is USB, this is w........
  • NS_ERROR_FAILURE (0x80004005) The virtual machine 'XP' has terminated unexpectedly during startup with exit code 1.


    The solution is to run '/etc/init.d/vboxdrv setup' and sometimes happens when upgrading VBox and the kernel modules don't get upgraded with it. Sometimes the above doesn't work until you reboot because sometimes other unknown processes (even the file manager possibly) may be locking the old module from being unloaded. Failed to open a session for the virtual machine XP. The virtual machine 'XP' has terminated unexpectedly during startup with exit code 1.........
  • Openvz iptables v1.4.7: can't initialize iptables table `nat': Table does not exist (do you need to insmod?) Perhaps iptables or your kernel needs to be upgraded. solution


    iptables -t nat -A PREROUTING -p tcp -m tcp -d 192.168.2.1/32 --dport 3389 -j DNAT --to-destination 192.168.5.2:3389 iptables v1.4.7: can't initialize iptables table `nat': Table does not exist (do you need to insmod?) Perhaps iptables or your kernel needs to be upgraded. The above is often because you don't have the correct modules loaded on the hostnode or enabled for the container but in some cases it's actually a weird openvz setting. Che........
  • LSI MegaRAID Adventures, Guide and HowTo


    LSi Megaraid At first it was configured as a RAID 0, then I deleted the Virtual Disk Group. I thought both drives would be shown and detected in Linux as sda and sdb but it actually shows nothing. To make them work you have to hit Ctrl+R before the system boots (when prompted) and create a Virtual Disk Group. In my case I created each one as RAID 0 (with a single drive only) as I just wanted JBOD but there is no such option or default in these Dell Pe........
  • kvm cannot boot xen guest using lvm


    This booting error is because the Xen PV guest image uses the Xen kernel, this is not compatible with anything but a host running a Xen kernel. I did a kpartx -av virtual.img and then it created some partitions that showed up in fdisk. I mounted it and did a chroot into it and removed the xen kernel and installed a normal kernel but Xen still shows the same kernel in Grub (only the Xen one). This is strange but it seems like this Xen PV guest has some sort of hidden or........
  • Creating tunnel gives the error ioctl: no such device


    ip tunnel add tun3 mode gre remote 192.58.1.5 ttl 64 ioctl: no such device I solved this on Centos by loading the ip_gre module: modprobe ip_gre On Debian I believe it is the "sit" module.........
  • mdadm how to add a device to an array after a failure


    This array is a RAID 1 and in this case 1 of the 2 drives failed (a WD drive and I've found them to be the weakest and most unreliable of any brand and are easily damaged/DOA when shipping them). mdadm --manage /dev/md0 --add /dev/sdb1 The above assumes the array you want to add to is /dev/md0 and the device we are adding is /dev/sdb1 *One thing to remember is to make sure the partition you are adding is the correct size for the array. You can also g........
  • Debian UUID not working


    Neither the blkid or the UUID internal to mdadm work to automount for some reason in Debian partprobe doesn't work but was a good suggestion from: http://pato.dudits.net/2008/11/03/special-device-uuidxxxxxxxxxxxxxxxx-does-not-exist-especially-with-lvm mount: special device /dev/disk/by-uuid/431b9b96-29e8f298-e89bd504-7065bddd does not exist mdadm -D /dev/md_d12 mdadm: metadata format 00.90 unknown, ignored. /dev/md_d12: &nb........
  • Centos Solution to "Warning: Unable to open /dev/fd0 read-write (Read-only file system). /dev/fd0 has been opened read-only."


    Warning: Unable to open /dev/fd0 read-write (Read-only file system). /dev/fd0 has been opened read-only. That's a very annoying error, it's simply because Centos for some reason thinks it's wise to load the "floppy" kernel module, who has a floppy drive? I haven't seen or used a floppy for over 12 years! It's more than just annoying, if you probe the drives attached to your system, eg. with grub or partprobe, it keeps trying to locate a flopp........
  • Linux - mptbase/MPT Fusion LSI Logic Error mptbase: ioc0: ERROR - didn't initialize properly! (-1)


    kernel 2.6.27.54 Fusion MPT base driver 3.04.07 Copyright (c) 1999-2008 LSI Corporation Fusion MPT SPI Host driver 3.04.07 mptbase: ioc0: Initiating bringup mptbase: ioc0: WARNING - Unexpected doorbell active! mptbase: ioc0: ERROR - Doorbell ACK timeout (count=4999), IntStatus=80000001! mptbase: ioc0: ERROR - Diagnostic reset FAILED! (102h) mptbase: ioc0: WARNING - NOT READY! mptbase: ioc0: ERROR - didn't initialize proper........
  • Ubuntu/Debian DRBD 8.0 Setup Guide


    I've only used it on Centos, soI thought I'd make a quick Debian guide: Install the DRBD Package apt-get install drbd8-utils Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: libswfdec-0.8-0 Use 'apt-get autoremove' to remove them. The following........
  • Buffer I/O error on device fd0, logical block 0


    Virtually no system has a floppy disk drive anymore but you will often find your Linux distribution insists that you do or should have one :) The solution is to remove the floppy module and prevent it from loading on the next reboot. rmmod floppy Centos/RHEL echo "blacklist floppy">> /etc/modprobe.d/blacklist Debian/Ubuntu sudo echo "blackli........
  • Openvz Error Starting OpenVZ: failed to load module vzmon [FAILED]


    service vz start Starting OpenVZ: failed to load module vzmon [FAILED] vzmon: Unknown symbol ve_snmp_proc_init vzmon: Unknown symbol addrconf_sysctl_free vzmon: Unknown symbol ve_ndisc_init vzmon: Unknown symbol addrconf_ifdown vzmon: Unknown symbol ip6_frag_cleanup vzmon: Unknown symbol fini_ve_route6........
  • Kernel Error - 2.6.35.2 stuck on the following: msgmni has been set to 1466 request_module: run away loop modprobe char-major-5-1


    2.6.35.2 stuck on the following: msgmni has been set to 1466 request_module: run away loop modprobe char-major-5-1 I don't know the fix for it, but it is an old bug that has reappeared.........
  • OpenVZ: failed to load module vzmon [FAILED] vzmon: Unknown symbol ve_snmp_proc_init vzmon: Unknown symbol addrconf_sysctl_free vzmon: Unknown symbol ve_ndisc_init vzmon: Unknown symbol addrconf_ifdown vzmon: Unknown symbol ip6_frag_cleanup vzm


    service vz start Starting OpenVZ: failed to load module vzmon [FAILED] vzmon: Unknown symbol ve_snmp_proc_init vzmon: Unknown symbol addrconf_sysctl_free vzmon: Unknown symbol ve_ndisc_init vzmon: Unknown symbol addrconf_ifdown vzmon: Unknown symbol ip6_frag_cleanup vzmon: Unknown symbol fini_ve_route6 ........
  • mdadm: /dev/sda1 is too small: 0K - solution


    I was creating a RAID array and got this error: mdadm: /dev/sda1 is too small: 0K mdadm: create aborted Of course sda1 is not too small, both partitions sda1 and sdb1 are identical in size: Disk /dev/sda: 2000.3 GB, 2000398934016 bytes 255 heads, 63 sectors/track, 243201 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Disk identifier: 0x00000000 Device Boot Sta........
  • CPanel OpenVZ VPS Error - *** Notice *** No working loopback device files found. Try running `modprobe loop` as root via ssh and running this script again.


    Ihave no idea how to get the loopback device working in OpenVZ, but what's more frustrating is that I purchased a CPanel license for my VPS and clearly it is not "VPS Optimized". Although everything does seem to work at this point despite that error. The suggestions here: http://forum.openvz.org/index.php?t=msg&goto=1339 don't seem to work at all. This is an OpenVZ issue, but also a CPanel isue, why on earth would loopback support be expected in a VPS a........
  • Starting online migration of CT 300 to 192.168.5.45 Error: vzcpt module is not loaded on the source node Error: Can't continue online migration Error: vzcpt module is not loaded on the source node Error: Can't continue online migration


    Starting online migration of CT 300 to 192.168.5.45 Error: vzcpt module is not loaded on the source node Error: Can't continue online migration Error: vzcpt module is not loaded on the source node Error: Can't continue online migration This is a very easy fix, you just load the appropriate modules on the source and target node (althoughI don't know why the vzmigrate tool can't do that for the user on both ends):........
  • Linux AHCI Hotswap Tips - Remember To Reread The Partition Table WITHOUT rebooting


    From the package "parted" you can use the command "partprobe" to re-read the partition table. I really hate rebooting, and that's what Iloved to hear about AHCI motherboards, that they allow hotswap so you don't have to reboot. But that's only as good as the OS, if the OS does not reload the partition table you won't be able to do anything with that new drive you attached without rebooting. Yes, even without re-reading the partiton table Linux will........
  • Using a Mac OSX DMG Image in Windows and Converting to Standard ISO Format use dmg2iso


    The dmg format is silly and annoying to work with, why couldn't Apple stick with the .iso standard? Anyway, there's an excellent Linux and Windows based tool to convert it back to a normal .iso Image called dmg2iso I'll only cover theLinux version although the Windows pre-built binary works the same way. Download dmg2iso here for free (from the author's website) It's just silly and doesn't make sense that Ubuntu doe........
  • SIOCSIFADDR No such device eth0 error while getting interface flags - eth0 Ethernet Device can


    Igot this after copying a VMWare image onto another machine in Debian. SIOCSIFADDR No such device eth0 error while getting interface flags The solution 1.) Find and edit the device line in persisent-net.rules note it will be prefixed with something like z25 or something else. vi /etc/udev/rules.d/z25_persistent-net.rules The easiest way is to comment anything out. If you are feeling........
  • Configuring OCFS2 Clustered File System on Debian Based Linux including Ubuntu and Kubuntu


    There's a lot of information and guides on OCFS2 for RHELand Centos Linux but the package setup and configuration is slightly different and this has thrown some people off. Installing OC2FS You should install the following packages to get started: apt-get install ocfs2-tools ocfs2console Configure OC2FS In RHEL/Centos the main configuration file is located in /etc/sysconfig/o2cb However in Debian based Linux it is located........
  • Latest Articles

  • Linux Ubuntu Cannot Print Large Images
  • Cannot Print PDF Solution and Howto Resize
  • Linux Console Login Screen TTY Change Message
  • Apache Cannot Start Listening Already on 0.0.0.0
  • MySQL Bash Query to pipe input directly without using heredoc trick
  • CentOS 6 and 7 / RHEL Persistent DHCP Solution
  • Debian Ubuntu Mint rc-local service startup error solution rc-local.service: Failed at step EXEC spawning /etc/rc.local: Exec format error
  • MySQL Cheatsheet Guide and Tutorial
  • bash script kill whois or other command that is running for too long
  • Linux tftp listens on all interfaces and IPs by DEFAULT Security Risk Hole Solution
  • python import docx error
  • Cisco Unified Communications Manager Express Cheatsheet CUCME CME
  • Linux Ubuntu Debian Missing privilege separation directory: /var/run/sshd
  • bash how to count the number of columns or words in a line
  • bash if statement how to test program output without assigning to variable
  • RTNETLINK answers: Network is unreachable
  • Centos 7 how to save iptables rules like Centos 6
  • nfs tuning maximum amount of connections
  • qemu-kvm error "Could not initialize SDL(No available video device) - exiting"
  • Centos 7 tftpd will not work with selinux enabled