/ - rtt - IT Resource

  • Centos 7 - Convert Minimal to Graphical GUI GNOME or KDE Desktop


    Did you just install the minimal version by accident or want to install the GUI?  No need to reinstall just tell yum to do the work for you! You could actually have both installed and choose one as your preference on demand (although many people prefer GNOME's simplicity). Step 1.) Install Gnome and/or KDE. To install the GNOME Desktop on Centos 7: yum -y groups install "GNOME Desktop" To........
  • Linux Mint Black Screen after boot no graphics solution


    This is not the normal "black screen" issue and I was shocked to eventually find out why.  The normal advice of reconfiguring Xorg didn't work.  Even booting into "Recovery Mode" did not help. Here is the short end of the stick that fixed it: sudo apt-get install mdm mate-desktop-environment Yes you got it right, mdm and the mate-desktop-environment / gnome were somehow uninstalled.  This must be whe........
  • Wine uninstalled broken on Linux Mint


    Solution: Aptitude is very smart and fixed the issues it was because of nvidia cuda and opencl and nothing else suggested or hinted this using apt sudo aptitude install wine The following NEW packages will be installed:   ocl-icd-libopencl1{ab} ocl-icd-libopencl1:i386{ab} wine wine1.6   wine1.6-amd64{a} wine1.6-i386:i386{a} The following packages will be REMOVED:........
  • Migrate Centos 7 from Single HDD to mdadm RAID 10 array:


    Done on Centos 7.3 very important as clearly based on older guides it was a lot easier and more simpler!  Hint do not use grub2-install! One huge caveat if you are an oldschool user or sysadmin who has avoided UEFI booting The normal way will not work here if your Centos was using UEFI.  Newer systems use it by default. The easiest way to check is to do an fdisk -l if your sy........
  • K9 Mail Android Cannot See or View E-mails Disappear after reading - with Dovecot server. Solution


    This actually only happened after an e-mail server ran out of space due to run away log files.  Normal Desktop clients were not affected.   It appeared to be a bug in K9 mail but even reinstalling/wiping all settings did not fix it (read e-mails would still not reappear). This is moreso a bug in Dovecot where it probably messes up the index files. How do you fix this in Dovecot/your e-mail server? You need to delete the do........
  • Centos 6 how to guide convert LVM non-RAID into mdadm 1/10 RAID array live without reinstalling


    Here is the scenario you or a client have a remote machine that was installed as a standard/default minimal Centos 6.x machine on a single disk with LVM for whatever reason.  Often many people do not know how to install it to a RAID array so it is common to have this problem and why reinstall if you don't need to?  In some cases on a remote system you can't easily reinstall without physical or KVM access. So in this case you add a second physical or disk or already ha........
  • Virtualbox errors on Ubuntu/Debian/Mint


      The solution was to reinstall the vbox dkms package and do a manual modprobe of the modules it makes. I never sorted out the unable to start due to the USB issue, I did have the guest additions installed but the only way to boot was to change the pointing device from USB to PS2 and then to disable the USB controller (if your pointing device is set as USB, disabling USB will not work because it will re-enable by default when it sees your pointing device is USB, this is w........
  • Dell CS24 NV5/NV7 Gigabyte GA-3CESL-RH Motherboard ROM Chip info


    If you remove the white label on the chip (near the CMOS battery) you will find the following details about it: SST 49LF080A 33-4C-NHE It is the PLCC32 type and can be pried and removed safely (but be very careful) with an eye glass flat head screw driver.  If you just have a bad flash you may be able to reprogram your original or just buy another one with the part# above and reprogram it. This is great news for people who have bricked th........
  • cPanel how to force reinstall rpms and fix packages and other problems caused by updates or duplicate rpms


    <p>If a service is not working and resetting it to defaults is not working and you get bizarre error messages it is probably a broken update and possibly duplicate package.</p> <p>Take in this case &quot;exim&quot; not working even after resetting to defaults.</p> <p><strong>Check for duplicates:</strong><code><br /> </code></p> <p><code>rpm -aq|grep exim<br /> </code></p> <p><c........
  • Vbox/Virtualbox devices grayed out for non-root user solution


    <p>It is a permissions issue that is hard to fix.</p> <p><strong>All but one USB device is greyed out.</strong></p> <p>I am already a member of &quot;vboxusers&quot;</p> <ul> <li>I have already enabled and disabled USB support for the guest.</li> <li>I have already reinstalled the latest VBOx guest editions</li> <li>If running as root it all works fine</li> <li>Changing........
  • NS_ERROR_FAILURE (0x80004005) The virtual machine 'XP' has terminated unexpectedly during startup with exit code 1.


    The solution is to run '/etc/init.d/vboxdrv setup' and sometimes happens when upgrading VBox and the kernel modules don't get upgraded with it.  Sometimes the above doesn't work until you reboot because sometimes other unknown processes (even the file manager possibly)  may be locking the old module from being unloaded. Failed to open a session for the virtual machine XP. The virtual machine 'XP' has terminated unexpectedly during startup with exit code 1.........
  • CPanel Link to all of the command line options


    <p>CPanel says you can access 98% of the functions through CLI which experienced Unix/Linux admins prefer for simplicity and for scripting.&nbsp; I've never found CPanel easy to use from the admin panel, it seems everything is hard to find and a simple task becomes a series of hunts.</p> <p>So for people like me here's the list: <a href="http://cpanel.net/system-administrators/command-line-scripts/">http://cpanel.net/system-administrators/command-line-scrip........
  • KVM Windows 7 won't boot Virtual Machine/VM after install solution


    This seems to be common for some reason when trying to run Windows 7 under KVM and 7 has always had strange issues with KVM.  What happens for me is after the install it simply won't boot, it stays on the POST screen and does nothing. For some reason it appears the boot sector either doesn't get installed or gets corrupted with KVM. The solution is to boot the install disc for Windows 7 and reinstall the windows MBR into the boot sector: 1. Boot t........
  • Ubuntu 10 Nvidia Drivers Not Updated After Kernel Update Solution/How-To Manually Rebuild nvidia kernel modules for Ubuntu


    I dread updating the kernel and rebooting to find the Ubuntu graphics aren't working and you have to manually intervene.   This is usually because Ubuntu for whatever reason didn't update the drivers you need (eg. the manually compiled Nvidia Kernel driver that MUST be recompiled for each and every kernel update unfortunately). The most common reason may be that "linux-source" hasn't been installed automatically on my system.  I tried to manually reinstall the........
  • ifup eth0 SIOCSIFFLAGS: Cannot allocate memory Failed to bring up eth0 Centos Network won't work after kernel update and reboot


    ifup eth0 SIOCSIFFLAGS: Cannot allocate memory Failed to bring up eth0 This is on a Centos 5.5 machine with OpenVZ kernel 2.6.18-238.12.1.el5.028stab091.1PAE, I updated 3 systems with the same hardware to the same kernel and for some reason the network didn't come back. This only happened once the first time I booted into the new kernel and hasn't happened again but this is a serious issue for those running systems from remote locations such as a datacente........
  • Openvz YUM Error Solution to "[Errno -1] Metadata file does not match checksum Trying other mirror."


    It's weird because I have a nearly identical box and setup and I can update the ovzkernel-PAE* just fine but on this box it doesn't work. I only get this error with the openvz.repo and not others such as Centos-Base.repo With my other server it works normally: ================ Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package ovzkernel-PAE.i686 0:2.6.18-238.12.1.el5.0........
  • PHP5 & Apache Blank/White Screen/Page PHP won't work


    PHP5 & Apache Blank Screen/Page The PHP package is installed and works from the CLI Error reporting is enabled The only way I could get it working was: rm /etc/php.ini yum remove php yum install php-* -x php-pear* -x php-pecl* Interestingly enough reinstalling php did not bring back the deleted php.ini but everything is working.  ........
  • Ubuntu 10.04/GNOME Volume Control Missing From Panel/Indicator Applet


    What this really refers to is gnome-volume-control-applet which is what controls the volume in the panel/indicator applet. In Ubuntu 10.04 it is just the applet mentioned above, run that from the command line and it will start. I lost mine when I removed pulseaudio trying to fix audio issues with Flash and Opera.  It also removes the gnome-volume-control-applet from starting.  *I also note........
  • Ubuntu 10.04/GRUB2 mdadm won't boot


    Moving to RAID was a pain. What you have to do is the following from an existing install: Install mdadm Create your mdadm RAID 1 array on your spare hard drive. Start it with the missing disk. rsync the entire contents of your current / to the md partition. Here's a good way of doing it: rsync -Pha --exclude=/proc/* --exclude=/sys/* --exclude=/mnt/* /. /mnt/md2........
  • Wine stopped working/won't work Solution


    After an upgrade wine wouldn't open anything, not even the pre-installed notepad. There are no wine logs and nothing is mentioned in any standard log file about why. I finally decided to run wine from the shell and see what's going on: wine client error:0: version mismatch 398/402. Your wineserver binary was not upgraded correctly, or you have an older one somewhere in your PATH. Or maybe the wrong wineserver is still running?........
  • MySQL Server 3.23 won't start after switching from 4.1


    MySQL Server 3.23 won't start after switching from 4.1I was using a 4.1 alpha version of mysql-server and some how version 3.23 of the client and 4.1 of the client were also both installed! So I forced uninstalled everything because after trying and trying even though MySQL server was using the short 16byte password authentication I got some other errors. After trying with the ports and having it fail because I had existing database data I force installe........
  • Latest Articles

  • How Does Cisco CUCM (Cisco Unified Communication Manager) Work?
  • What DNS Options Does Active Directory Offer in Windows Server 2008,2012,2016 ?
  • syntax error, unexpected T_SL in PHP Solution
  • grep regular expression match number range between specific numbers
  • bash how to print out lines of text within a range from the first occurrence
  • bash script how to to check LAN computers for open ports
  • MySQL Using mytop Debug Source of High IO and Slow Performance
  • How To Mathematically Convert and Calculate Binary Value To Decimal Value
  • systemd management using systemctl and journalctl to check systemd logs
  • css how to format code in the code tag
  • css br with extra blank line
  • What is /dev/pts and why do we need it in Linux?
  • Linux What is umask (user mask) for file and directory creation permissions and how to calculate umask and change the defaults
  • Linux Permissions and Groups Real Usecase for Group Access
  • Centos 7 python34 how to install the gi library
  • Centos 7 - Convert Minimal to Graphical GUI GNOME or KDE Desktop
  • AMD Set Fan Speed and Other Powerplay Memory/CPU Timings with a Linux script
  • Ethereum Mining Claymore Nanopool Error
  • genisoimage errors with long filenames and deep directory structures
  • Linux Kernel USB Export Errors