• Asterisk Does Not Retry When Authentication Fails


    When authentication times out that is one thing, but when it just fails like below Asterisk by default will not re-register until you the admin reload the sip or asterisk server: voipserver*CLI> sip show registry Host dnsmgr Username Refresh State&........
  • httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/php.conf: Cannot load modules/libphp5.so into server: /lib64/libresolv.so.2: symbol __h_errno, version GLIBC_PRIVATE not defined in file libc.s


    httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/php.conf: Cannot load modules/libphp5.so into server: /lib64/libresolv.so.2: symbol __h_errno, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference This is usually caused by a mismatch in OpenSSLversion. Interestingly enough a lot of times if it has happened during an update of your system, or after, usually just restarting httpd........
  • how to use ifplugd in Linux to execute a command or script when a NIC cable is unplugged or plugged in


    It is fairly simple to use once you know how to use it. However, the tricky thing is that by default it doesn't seem to be active or listen on any interface on manually specified. How To Install ifplugd First we install ifplugd sudo apt install ifplugd Let's enable it on our desired device(s) vi /etc/default/ifplugd set this line as so:........
  • genisoimage errors with long filenames and deep directory structures


    You'll have to violate the iso9660 standards but it is necessary if you want to preserve your filesystem and filenames and shouldn't be an issue as long as you are using a modern OS like Linux. genisoimage -o Backup-Myfiles.iso -r -J -joliet-long /some/path/ You will get errors like below (even enabling joliet-long didn't help) genisoimage: Error: /some/filename.pdf have the same Joliet name Joliet tree sort failed. The -joliet-lo........
  • mdadm change wrong device name md127 fix and solution in Linux


    md127 issue, it should be /dev/md3 per mdadm.conf Any time something is mounted as md127 it almost always means there is no entry for this mdadm array in the mdadm.conf in initramfs (which is separate from your actual /etc/mdadm.conf). cat /etc/mdadm.conf ARRAY /dev/md3 metadata=1.2 UUID=b6722845:381cc94e:7a2c5b5f:8e3b7c4f The reason for this is something strange, most Linux OS's bizarrely always keep their own copy of /etc/mdadm.con........
  • 99.99 % [jbd2/drbd0-8] highiowait


    I have not found the source of this but essentially it seems like drbd and ext4 may not play well but I have to confirm still. In either case an older DRBD setup with older hard drives seems to have little to no iowait, but the main difference is the drbd partition is ext3 and not ext4. I will experiment and see if that fixes this, then we will know that DRBD and ext4 have issues.........
  • Weird Ubuntu Issues with NVIDIA driver/Compiz


    1.) My screensaver would take a long time to disable after hitting a key. 2.) Usually errors like below will follow. 3.) Compiz sometimes uses 100% or high CPU 4.) My window controls will disable (eg. the minimize, maximize and close buttons). It seems like Compiz or appearance/effects disable themselves. Re-enabling Desktop Effects under Appearance temporarily fixes it. 5.) high load in general from things like "Migration" pr........
  • Asterisk iptables block bruteforce attacks howto with fail2ban


    yum -y install fail2ban vi /etc/fail2ban/jail.conf [asterisk-tcp] enabled = true filter = asterisk action = iptables-multiport[name=asterisk-tcp, port="5060,5061", protocol=tcp] sendmail-whois[name=Asterisk, dest=you@example.com, sender=fail2ban@example.com] logpath = /var/log/asterisk/messages maxret........
  • LSI MegaRAID Adventures, Guide and HowTo


    LSi Megaraid At first it was configured as a RAID 0, then I deleted the Virtual Disk Group. I thought both drives would be shown and detected in Linux as sda and sdb but it actually shows nothing. To make them work you have to hit Ctrl+R before the system boots (when prompted) and create a Virtual Disk Group. In my case I created each one as RAID 0 (with a single drive only) as I just wanted JBOD but there is no such option or default in these Dell Pe........
  • Ubuntu 10.04 Flash Videos have tearing/lines Solution


    This is what I call a ridiculous bug in compiz that causes it. The solution/To fix it just install "compizconfig-settings-manager" Open it up and Navigate to General Options -> Display Settings Set the "Refresh Rate" to the current refresh rate of your monitor. For ATI cards with slow window dragging/response supposedly disabling "Sync to VBlank" fixes that but otherwise leave it as is.........
  • DRBD WFConnection Problem/Solution


    This has stumped me a few times because I keep forgetting that Centos 5.5 comes with a default iptables configuration that ends up blocking DRBD traffic,I tried all the normal things and couldn't understand why I couldn't make my normal DRBD config work. So if you have WFConnection problems and have tried the normal "mailing list" fixes, check your firewall status first! Both Nodes Say the Following: version: 8.3.8 (api:88/prot........
  • Asus O!Play cannot access network/workgroup shares


    It always worked fine before but no amount of power unplugging/cycling does any good. I can access one network share and that is one that I've already saved, but it can't see any workgroups. One silly thing is why is there no option to manually connect to a netbios name or IP? It seems there is a bug with the firmware and that the SMB client is not working properly. Hopefully it fixes itself at some point. Between this and the lack of support for embedded s........
  • sudo: Error dropping capabilities, aborting in Linux Centos 5.3


    For some reason Ikeep getting this error when trying to run a sudo command eg: sudo -u someuser somecommand sudo: Error dropping capabilities, aborting My version of sudo is:sudo-1.6.9p17-3.el5_3.1 and I've heard that version 1.7 fixes everything. The only thing is yum does not think sudo has any update. Iguess the new version has not been committed to the RPM repository yet. This is really a huge and ann........
  • Latest Articles

  • Aruba/HP/Dell IAP Wireless Controller Common Default Passwords
  • Debian, Mint Ubuntu how to remove package and associated config files
  • Linux Grub not booting the intended kernel solution in Debian, Mint, Ubuntu how to specify which kernel to boot by default
  • QEMU KVM Keyboard Problems Not Working Right Repeating Characters, Ctrl+C Copy and Paste not working right when using PS2 mouse in guests Solution
  • Linux how to compile binary with static sharedobjects embedded instead of dynamic to use on multi-distributions and avoid glibc compatiblity issues
  • /bin/sh: msgfmt: not found error solution on Linux Compilation Ubuntu Debian Mint Centos
  • Mikrotik RouterOS CHR/ISO Basic and Quick Setup Howto Guide
  • qemu 4 compilation options
  • CentOS 7 8 PXEBoot Netinstall Not Working Solution "Pane is dead "new value non-exisetnt xfs filesystem is not valid as a default fs type"
  • CentOS 6 EOL yum repo won't work Error: Cannot find a valid baseurl for repo: base Solution
  • CentOS 7 8 How To Disable SELinux
  • Wordpress How To Add Featured Image To Post in Hueman Theme
  • kdenlive full reset how to erase all config files
  • CentOS 7 8 yum error Trying other mirror. To address this issue please refer to the below wiki article
  • Microsoft Teams Linux - Calendar Doesn't Work Missed Meetings!
  • Scanner not working in Linux Ubuntu Fedora Mint Debian over the network? Use sane-airscan!
  • How To Boot, Install and Run Windows 2000 on QEMU-KVM
  • bash cannot execute permission denied
  • Huion and Wacom Tablets How To Install in Linux Mint / Ubuntu and make the stylus work properly
  • ffmpeg how to cut certain parts of video out