• zfs and LUKS how to recover in Linux


    Sometimes users take their removal drives and unplug and replug them to test what happens during the failure of a disk. However, this breaks things quite badly due to the /dev/mapper in LUKS not coming back online due to it not being closed. In other words, generally with non-encrypted drives the process is smooth but when encrypted you may want to follow a strategy like this: We can see below that both disks are unavailable as they were physically remov........
  • LightDM Mint Ubuntu Debian won't start errors Nvidia Graphics


    This error implies that there may be an issue with Xorg or maybe your NVIDIA GPU cannot start or initialize: 35 laptop kernel: [ 2031.857704] nvidia: loading out-of-tree module taints kernel. 35 laptop kernel: [ 2031.857724] nvidia: module license 'NVIDIA' taints kernel. 35 laptop kernel: [ 2031.857725] Disabling lock debugging due to kernel taint 35 laptop kernel: [ 2031.873280] nvidia: module verification failed: signature a........
  • LXC Containers LXD How to Install and Configure Tutorial Ubuntu Debian Mint


    If you are using mint, delete the preference that stops snap from installing (as it is required for lxc) sudo rm /etc/apt/preferences.d/nosnap.pref 1. Install lxd: sudo apt install lxd Issues install lxd or errors? Click here Debian at this time does not have lxd so you'll need to use snap: sudo apt in........
  • Ceph Install Errors on Proxmox / How To Fix Solution


    This normally happens when you interrupt the install of Ceph: pveceph install update available package list start installation Reading package lists... Done Building dependency tree... Done Reading state information... Done gdisk is already the newest version (1.0.6-1.1). ceph-common is already the newest version (15.2.15-pve1). ceph-fuse is already the newest version (15.2.15-pve1). Some package........
  • EFI PXE grub2 Howto guide for Linux EFI PXE Booting on Debian, Mint, Ubuntu, RHEL


    Just a quick note and warning is that if you are testing to see if EFIPXE booting works on a VM, MAKE SURE it actually works. For example Iinitially tested using my Distro's QEMU 2.5+dfsg-5ubuntu10.46 and ovmf BIOS firmware (OVMF supports EFI). However, I found on old versions of QEMU (like 2.5), EFIbooting with GRUB NEVER works so it may appear that you have made a mistake when everything is fine when you boot a physi........
  • Huion and Wacom Tablets How To Install in Linux Mint / Ubuntu and make the stylus work properly


    It took a lot of fiddling to make a Huion Kamvas 13 Pro work in Linux but it simple once you know what to do. Don't bother searching as it is unlkely there is a guide out there that will actually make your tablet work. It mainly comes down to the fact that the hid_uclogic kernel module is buggy or doesn't support MANYof these wacom based/Huion tablets properly. What was happening with me is that Ihad the Kamvas 13 Huion setup as a secondary screen/monitor.&nb........
  • CentOS 6 impossible to compile a newer libguestfs


    yum -y install gcc make gperf genisoimage flex bison ncurses ncurses-devel pcre-devel augeas-devel augeas readline-devel checking for cpio... cpio checking for gperf... no configure: error: gperf must be installed configure: error: Package requirements (augeas >= 1.2.0) were not met: Requested 'augeas >= 1.2.0' but version of augeas is 1.0.0 yum remove augeas augeas-libs augeas-devel wget http://downl........
  • Ubuntu Debian Linux Cannot Install Wine Solution - wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu14.2) but it is not installable wine1.4 : Depends: wine1.6 but it is not going to be installed


    If you've ever gotten errors like this the solution is simple, you need i386 enabled on your 64-bit install because wine depends on some 32-bit x86 libraries: dpkg --add-architecture i386 apt update apt install wine After that it will install just fine. apt install wine Reading package lists... Done Building dependency tree Reading state information... Done........
  • Cisco Unified Communications Manager 12 Install Errors on Proxmox/KVM


    The strange thing is that usually the first install or two will work on any new machine but then it suddenly won't. I had this experience on QEMU 2.13 on a different machine. There is something finicky or buggy about the CUCM installer even when choosing the same virtual hardware specs. qemu-kvm command: /usr/libexec/qemu-kvm -version QEMU PC emulator version 0.12.1 (qemu-kvm-0.12.1.2-2.506.el6_10.1), Copyright (c) 2003-2008 Fabrice Bellard ........
  • Cisco Switch Reset To Factory Defaults


    This works on the 2000 and 3000 series generally. *The easy way is to just hold the mode button for 10+ seconds. The full/proper way is below: 1.) Either power on the unit and hold the "mode" button or hold the "mode" button until you see the below: 00:04:08: %SYS-7-NV_BLOCK_INIT: Initalized the geometry of nvram 00:04:08: %EXPRESS_SETUP-6-CONFIG_IS_RESET: The configur........
  • SSH error cannot Forward or Listen "bind: Cannot assign requested address"


    debug1: Local connections to LOCALHOST:18006 forwarded to remote address 192.168.1.93:8006 debug1: Local forwarding listening on 127.0.0.1 port 18006. debug1: channel 0: new [port listener] debug1: Local forwarding listening on ::1 port 18006. bind: Cannot assign requested address What we are seeing is that we can't listen on an IPV6 address of ::1. We need to tell SSH to stop using IPV6 so we'll edit ssh_config to take care of this issue........
  • Debian Mint Ubuntu compiling xmr-stak


    sudo apt-get install libcurl4-openssl-dev git build-essential autotools-dev autoconf libcurl3 sudo apt-get install libcurl4-gnutls-dev git clone https://github.com/wolf9466/cpuminer-multi sudo apt-get install cmake libpthread-* libmicrohttpd-dev libssl-dev libhwloc-dev git clone https://github.com/fireice-uk/xmr-stak-cpu.git make install cd bin chmod +x xmr-stak-cpu ./xmr-stak -O xmr........
  • kdenlive titles/text renders as white screen when using .sh script


    When using the .sh script the rendering doesn't work after an upgrade of related packages to kdenlive. kdenlive (kdenlive:amd64 (4:17.04.1+git201705191233~ubuntu16.04.1)) with affine or composite transitions was fine but is now broken during the time of transition it is just a white screen. The previous version was fine: kdenlive:amd64 (4:17.04.1+git201705191233~ubuntu16.04.1 But now I can't find it or install it:........
  • Wine uninstalled broken on Linux Mint


    Solution: Aptitude is very smart and fixed the issues it was because of nvidia cuda and opencl and nothing else suggested or hinted this using apt sudo aptitude install wine The following NEW packages will be installed: ocl-icd-libopencl1{ab} ocl-icd-libopencl1:i386{ab} wine wine1.6 wine1.6-amd64{a} wine1.6-i386:i386{a} The following packages will be REMOVED:........
  • PYCURL ERROR 22 - The requested URL returned error: 404 Not Found Solution


    # yum -y install qemu-kvm Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirror.lzu.edu.cn * elrepo: ftp.utexas.edu * epel: ftp.jaist.ac.jp * extras: mirrors.aliyun.com * openvz-kernel-rhel6: mirror.fdcservers.net * openvz-utils: mirror.fdcservers.net * updates: mirrors.nwsuaf.edu.cn Resolving Dependencies........
  • Linux Mint/Ubuntu/Debian Dual NICs networks problem when enabling and disabling one device


    The Scenario You have dual NICs and you disable NIC1 which uses 192.168.1.1 as its gateway. With NIC2 you enable it/connect it to another network which also has the gateway 192.168.1.1 Everything will work fine at this point. When switching back to NIC1 even with NIC2 disabled and even unplugged, the OS basically can't pick up the new/updated ARP entry of the old device for 192.168.1.1 and perhaps thinks it is a security risk or spoof of some sorts and blocks i........
  • Cannot get mono to work properly on Linux Mint


    mono/wine not working in Ubuntu/Linux Mint/Debian: The assembly mscorlib.dll was not found or could not be loaded. It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory. solution: sudo apt-get install mono-complete Problems: mono does not work well for even simple things like a Winrar self extracting .exe fi........
  • openvz yum problem Centos 6.5 cannot find file on mirror:


    #solution Edit /etc/yum.repos.d/openvz.repo For the first two entries comment out #mirrorlist and uncomment #baseurl and then it worked openvz yum problem Centos 6.5 cannot find file on mirror: yum update Loaded plugins: fastestmirror Determining fastest mirrors * openvz-kernel-rhel6: mirrors.ustc.edu.cn * openvz-utils: mirrors.ustc.edu.cn base ........
  • Centos yum mirror problem error "[Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found""


    [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" The above happened when for some reason all the mirrors in my cache didn't have the files (some mirrors only keep the latest version of Centos). Itried to block them all but that didn't help because it seemed the mirrors were all hardcoded no matter what I tried. Here is how to fix it and reset your mirror list in Centos cd /var/cac........
  • Dell Perc 6/i cannot downgrade


    I flashed an LSI Logic firmware to it and it broke the BIOS (cannot do Ctrl+R) for booting purposes but allows other functionality to work normally. I tried downgrading to a Dell firmware for Perc 6i but it won't work, not even with MegaCli wget http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN --2013-08-26 12:53:39-- http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN Resolvi........
  • WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!


    The easiest way is if you have a secure way to connect and verify the hostkey of the remote host by using this guide. @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ IT IS POSSIBLE THAT SOMEONE IS DOING SOME........
  • Samba SMB Error - Server not using user level security and no password supplied. tree connect failed: NT_STATUS_WRONG_PASSWORD


    Server not using user level security and no password supplied. tree connect failed: NT_STATUS_WRONG_PASSWORD That happens when trying to use smbclient to connect to a share. The weird thing is that I can authnenticate just fine from Windows XP. It is partially my mistake, I forgot this share does have a password. I've tried authenticating with the correct user and also with "Guest" because this works in Windows. In Linux I ........
  • Latest Articles

  • qemu: could not load PC BIOS 'bios-256k.bin' solution
  • Proxmox How To Custom Partition During Install
  • Hyper-V Linux VM Boots to Black Screen, Storage, NIC Not Found Issues
  • Ubuntu Mint How to Fix Missing/Broken /dev and /dev/pts which causes terminal to immediately close exit and not work
  • How high can a Xeon CPU get?
  • bash fix PATH environment variable "command not found" solution
  • Ubuntu Linux Mint Debian Redhat Youtube Cannot Play HD or 4K videos, dropped frames or high CPU usage with Nvidia or AMD Driver
  • hostapd example configuration for high speed AC on 5GHz using WPA2
  • hostapd how to enable and use WPS to connect wireless devices like printers
  • Dell Server Workstation iDRAC Dead after Firmware Update Solution R720, R320, R730
  • Cloned VM/Server/Computer in Linux won't boot and goes to initramfs busybox Solution
  • How To Add Windows 7 8 10 11 to GRUB Boot List Dual Booting
  • How to configure OpenDKIM on Linux with Postfix and setup bind zonefile
  • Debian Ubuntu 10/11/12 Linux how to get tftpd-hpa server setup tutorial
  • efibootmgr: option requires an argument -- 'd' efibootmgr version 15 grub-install.real: error: efibootmgr failed to register the boot entry: Operation not permitted.
  • Apache Error Won't start SSL Cert Issue Solution Unable to configure verify locations for client authentication SSL Library Error: 151441510 error:0906D066:PEM routines:PEM_read_bio:bad end line SSL Library Error: 185090057 error:0B084009:x509 certif
  • Linux Debian Mint Ubuntu Bridge br0 gets random IP
  • redis requirements
  • How to kill a docker swarm
  • docker swarm silly issues