• Linux Debian Ubuntu How To Install PEPPER Faster and Latest Adobe Flash Player in Firefox


    Just run this apt install command sudo apt install pepperflashplugin-nonfree browser-plugin-freshplayer-pepperflash After this restart your browser and check Adobe's site to verify if your Pepper flash is working and showing at least version 32. https://helpx.adobe.com/flash-player.html As you'll see below it will download the latest version which is currently 32 and this was not possible with the old/crappy deprecated adobe-flash plu........
  • How To Install OpenProject on Centos 7 Step-by-Step Guide


    There are a few caveats that may not be obvious to everyone so I am going to cover them here but keep this in mind before starting. #1) When you specify your SSL certificate with a full path, it really needs to exist where you tell it to (including the default location of /etc/ssl/certs and /etc/ssl/certs/private). Also note to make a cert there is a quick shell script in /etc/ssl/certs called "make-dummy-cert" that you can run to make the cert.........
  • Ubuntu Debian Linux Cannot Install Wine Solution - wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu14.2) but it is not installable wine1.4 : Depends: wine1.6 but it is not going to be installed


    If you've ever gotten errors like this the solution is simple, you need i386 enabled on your 64-bit install because wine depends on some 32-bit x86 libraries: dpkg --add-architecture i386 apt update apt install wine After that it will install just fine. apt install wine Reading package lists... Done Building dependency tree Reading state information... Done........
  • How To Install python 3.4 3.5 and up on Linux with wine - Working Solution


    This is sure simple if you follow the guide but it took a lot of hacking around to make this work on Debian/Ubuntu! Now before you ask why bother running wine and python, the reason is because Python executables are NOT cross-platform. If you run pyinstaller in Linux, that binary will only run on Linux and the same if you do it in Windows. So it is preferable if you have a single environment that you can create Linux and Windows binaries from rather than running 2 separate........
  • Convert and install to LUKS Encrypted Drive Ubuntu 18.04 19.10 Linux Mint and Debian Based Linux


    The reason for doing this is that the installer doesn't seem to work properly for LUKS and the server installer doesn't even support LUKS anymore. When you use the GUI install on Desktop for LUKS it won't boot and will just hang after you enter your password. So the only reliable way is to do it ourselves. 1.) Make a default minimal install of Ubuntu 2.) Have a secondary disk on the server or VM. 3.)........
  • Cisco Unified Communications Manager / CUCM IP 8.6,10,12 Install Error Solution


    Install Errors on Version 12: This error happened on QEMU emulator version 2.11.1 pve-qemu-kvm_2.11.1-5 on Proxmox/Debian but installing on QEMU.12 on Centos 6 did not produce the error. *Update it is not related to the OS or QEMU version. This happened in Centos 6 too after a second install. What really causes this even though you successfully install........
  • Cisco Unified Communications Manager 12 Install Errors on Proxmox/KVM


    The strange thing is that usually the first install or two will work on any new machine but then it suddenly won't. I had this experience on QEMU 2.13 on a different machine. There is something finicky or buggy about the CUCM installer even when choosing the same virtual hardware specs. qemu-kvm command: /usr/libexec/qemu-kvm -version QEMU PC emulator version 0.12.1 (qemu-kvm-0.12.1.2-2.506.el6_10.1), Copyright (c) 2003-2008 Fabrice Bellard ........
  • LUKS Hard Drive Encryption on Linux Mint Ubuntu Debian etc how to mount encrypted hard drive


    The key thing here is to know the actual partition that is encrypted. Often in Linux Mint's installer that ends up being partition 5 or /dev/sda5 sudo cryptsetup luksOpen /dev/sda5 anynamehere You will then be prompted for your irrecoverable passphrase: Enter passphrase for /dev/sda5: If all goes well it won't say anything further. If it says ""No key available with this passphr........
  • letsencrypt certbot error "Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80."


    ./certbot-auto --apache certonly Saving debug log to /var/log/letsencrypt/letsencrypt.log Plugins selected: Authenticator apache, Installer apache No names were found in your configuration files. Please enter in your domain name(s) (comma and/or space separated) (Enter 'c' to cancel): yourdomain.com Obtaining a new certificate Performing the following challenges: http-01 challenge for yourdomain.com Cleaning........
  • HP DL385 G7 Linux BIOS Update Flash


    wget https://downloads.linux.hpe.com/repo/spp/rhel/6/x86_64/current/CP017004.scexe --2018-08-16 05:11:16-- https://downloads.linux.hpe.com/repo/spp/rhel/6/x86_64/current/CP017004.scexe Resolving downloads.linux.hpe.com (downloads.linux.hpe.com)... 15.249.152.85 Connecting to downloads.linux.hpe.com (downloads.linux.hpe.com)|15.249.152.85|:443... connected. HTTP request sent, awaiting response... 200 OK Length: 1525561 (1.5........
  • VMWare Vsphere VCSA Graphical Install Creates json


    yes it does create its own json ============================================ cat /tmp/vcsaUiInstaller/ovftool-20180809-175238948-20180809-175603497.log |grep -i json 2018-08-09T17:56:04.238-07:00 verbose OVFTool[30966] [Originator@6876 sub=Default] Manifest file entry: SHA1(VMware-vCenter-Server-Appliance-6.7.0.12000-8832884_OVF10-file1.json) = 1deb658c724767697587d5909c4051c01813e6a1 --> ........
  • Debian Mint Ubuntu compiling xmr-stak


    sudo apt-get install libcurl4-openssl-dev git build-essential autotools-dev autoconf libcurl3 sudo apt-get install libcurl4-gnutls-dev git clone https://github.com/wolf9466/cpuminer-multi sudo apt-get install cmake libpthread-* libmicrohttpd-dev libssl-dev libhwloc-dev git clone https://github.com/fireice-uk/xmr-stak-cpu.git make install cd bin chmod +x xmr-stak-cpu ./xmr-stak -O xmr........
  • OVF Tool: Error: Task failed on server: This host does not support Intel VT-x. VMWare VCenter install On ESXi ERror


    Intel VT-X is enabled in Virtualbox but it doesn't seem to pass through the needed vmx extension despite the following variables on the host confirming it is enabled: cat /sys/module/kvm_intel/parameters/nested Y cat /sys/module/kvm_intel/parameters/ept Y OVF Tool: Disk progress: 99% OVF Tool: Transfer Completed OVF Tool: Powering on VM: Embedded-vCenter-Server-Appliance- OVF Tool: Task p........
  • VMWare 6.7 VCSA VSphere ESXi Management SSO Install Guide on Linux using the CLI


    #mount the VCSA DVD mount /dev/sr0 /mnt/cd #alternatively you could mount the iso directly mount -o loop vcsa.iso /your/mount/path #for this purpose we are using the CLI installer on Linux cd /mnt/cd/vcsa-cli-installer/lin64 #no it's not going to be that easy you can't just run vcsa-deploy like that you need to use a template or configured .json file ./vcsa-deploy Usage: vcsa-deploy [-h] [--version] [--supported-deploymen........
  • Centos 7 Root Password Reset


    In Centos 7 the days of editing the "kernel"line and adding "single"are gone. On top of that sometimes after a new install passwords do not work, maybe you forgot your password or for some other reason you need to break in or fix your system? It could also be because you can't mount your root / or some other /etc/fstab error and many other errors. Short Version: 1. Edit your grub settings and find the linux16 /vmlinu........
  • Debian/Mint/Ubuntu Font Packs/Recommended To Install


    This will give you a lot more nice fonts to work with. Usually you must restart the program you are using to see the new fonts. ttf-mscorefonts-installer fonts-larabie-* ttf-xfree86-* ubuntustudio-fonts ttf-* fonts-*........
  • Centos 7 Cudaminer Nvidia setup guide


    I am using a GTX 1060 but replace the download for the driver with the correct/current version for your particular card by visiting: http://www.nvidia.com/Download/index.aspx?lang=en-us yum install automake curl openssl-devel libcurl-devel gcc gcc-c++ yum -y install kernel-devel-`uname -r` yum -y install unzip #the........
  • Intel NUC J3455 Linux Support Ubuntu/Linux Mint Issues


    I get the following error "Installer Crashed" on 18.1 MATE 64-bit when installing by NFS/PXE. Yet it was able to at least detect and use my NIC (perhaps the driver was only activated because of PXE/NFS being used)? When using 18.1 Cinnamon on CD the NIC does not work but the installer did succeed. However it doesn't work right, I can't login graphically and get some Cinnamon OOMerror but how can this be with 8GB of RAM straight from login?........
  • Linux Mint Install Netboot PXE Guide Howto


    *Update so this doesn't work it must be something to do with the path of nfs or something else but the installer fails with "Installer crashed" at the end whereas with the CD/USB it works. This assumes you've already installed and configured a separate PXE/DHCP server somewhere else and your /tftpboot directory is setup. This is for Linux Mint 18.1 but generally applies to most versions although you may have tro change things like "casper"........
  • Setting Up System for First Use... Please Wait... - WHMCS Installer


    This happens sometimes that it takes a fair amount of time for some WHMCS installations but it usually ends up completing eventually.........
  • cPanel Install Error kernel ipv6 module support solution


    2017-01-12 14:25:36 529 (ERROR): The installer was unable to verify that your kernel supports IPv6. 2017-01-12 14:25:36 530 (ERROR): The message received when trying to create an IPv6 socket was Address already in use 2017-01-12 14:25:36 531 (ERROR): Please ensure that the ipv6 module is enabled and loaded in your kernel. 2017-01-12 14:25:36 532 (FATAL): Exiting... Solution This happened........
  • SAS2008 LSI 9200-E Linux Upgrade Flash Firmware with sas2flash


    Download from here http://www.avagotech.com/products/server-storage/host-bus-adapters/sas-9200-8e#downloads sudo Installer_P20_for_Linux/sas2flash_linux_i686_x86-64_rel/sas2flash -listall LSI Corporation SAS2 Flash Utility Version 20.00.00.00 (2014.09.18) Copyright (c) 2008-2014 LSI Corporation. All rights reserved &nbs........
  • How To Install Linux Mint 17.2 on mdadm RAID with a separate boot partition


    Iwas surprised to see that Linux Mint at the latest 17.2 version still has NO mdadm installer option, and worse the installer will not be able to create a proper booting environment even when you do install it. How to setup mdadm in Linux mint LiveCD sudo su apt-get install mdadm # partition as you need and then create your mdadm devices # create your SWAP md0 mdadm --create /dev/md0 --level=1 --raid-devices=2 /dev/sda1 /d........
  • KVM on Centos 6.3 cannot boot FreeBSD 9.2 AMD64


    On the same OS with the same kernels basically I cannot boot FreeBSD installer, I believe the issue is the host CPU. One host runs an Intel and works, while an Opteron 2373 does not work despite suggestions from this thread: http://149.20.54.209/showthread.php?t=36761 I've tried cpu options like "kvm64" "Opteron_G3" and none........
  • Dell Perci 6/i Firmware Upgrade Guide Tutorial


    One thing to remember is that you need MegaCli to do the flashing. You also need the correct file,I tried at least 2 different Perc 6 firmwares from Dell that kept getting rejected as corrupt by MegaCli(they were really the wrong version). I have an external PCI-E Dell 6 Perc/I butI chose images from the 'Integrated" on motherboard version as it was allI could find. They are different, and below is my first time finding success.........
  • Dell Perc 6/i cannot downgrade


    I flashed an LSI Logic firmware to it and it broke the BIOS (cannot do Ctrl+R) for booting purposes but allows other functionality to work normally. I tried downgrading to a Dell firmware for Perc 6i but it won't work, not even with MegaCli wget http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN --2013-08-26 12:53:39-- http://downloads.dell.com/FOLDER00416606M/1/SAS-RAID_Firmware_W83M2_LN32_6.3.1-0003_A14.BIN Resolvi........
  • KVM support Ubuntu 12.04 or 12.10


    This seems to be a verified bug on KVM with no solution. I wasn't able to get through the installer with Ubuntu 12.04, it would crash while "configuring apt". I was able to install it with Ubuntu 12.10 but it crashes randomly at times. This happens with the latest Centos 6.3 kernel and KVM package, I even compiled the latest version from the KVM website and used that, but the results are still the same. Here's some links to discussion about the bugs:........
  • Drupal 6.2 Install and how to move install to root/non-subdirectory


    drup 6.2 install $cd drupgoodinst3883/ [ drupgoodinst3883]$ ls CHANGELOG.txt cron.php index.php INSTALL.pgsql.txt INSTALL.txt MAINTAINERS.txt modules robots.txt sites update.php xmlrpc.php COPYRIGHT.txt includes INSTALL.mysql.txt install.php LICENSE.txt misc&........
  • Use rcconf to edit startup/init.d/init scripts on Debian/Ubuntu based distributions


    I've never understood how to enable and disable services for different run levels in Debian based distros, it's just weird, annoying and doesn't make sense. I much prefer chkconfig from RHEL. Just install the package called 'rcconf' and be done with it. rcconf makes things easy for you. apt-get install rcconf Reading package lists... Done Building dependency tree Reading state information... Done........
  • Debian 5.04 RAID 1 mdadm boot problem GRUB error


    I successfully created a single RAID 1 partition which includes /boot inside it and my root directory through the Debian installer. It said GRUB installed successfully but when I try booting the OS it seems GRUB can't read anything. When trying to boot from GRUB GRUB Loading stage 1.5. GRUB loading, please wait... Error 2 I get "Error 2" when trying to boot Debian. I also notice from a LiveCD that........
  • InnoDB is a free installer for Windows based systems


    InnoSetup is something Ijust realized many commercial developers use for installation. Why? Because it's100% FREE, simple, and efficient to use. The maker has really done a great job and the installer basically works on all versions of Windows since 95. I'll keep this in mind the next time I code a Windows application since it's been years for me.........
  • Latest Articles

  • virt-resize: error: libguestfs error: could not create appliance through libvirt.
  • Asterisk Does Not Retry When Authentication Fails
  • Linux Debian Ubuntu How To Install PEPPER Faster and Latest Adobe Flash Player in Firefox
  • How To Speed Up Linux Ubuntu and Debian Based Computers By Improving CPU Performance and Changing the CPU Governor
  • Convert data or file to base64 on a single line
  • Linux Mint Ubuntu Debian radeon slow 2D performance issues radeon_dp_aux_transfer_native: 158 callbacks suppressed
  • mdadm: super0.90 cannot open /dev/sdb1: Device or resource busy mdadm: /dev/sdb1 is not suitable for this array.
  • How To Install NextCloud on Centos 7 and Centos 8
  • AH01630: client denied by server configuration:
  • ERROR: Could not find a version that satisfies the requirement PIL (from versions: none) ERROR: No matching distribution found for PIL
  • ZTE Camera Cannot Work unable to connect to camera. Camera has been disabled becaue of security policies or is being used by other apps
  • QEMU KVM how to boot off a physical CD/DVD/BDROM Drive
  • How To Install OpenProject on Centos 7 Step-by-Step Guide
  • Ubuntu Debian Linux Cannot Install Wine Solution - wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu14.2) but it is not installable wine1.4 : Depends: wine1.6 but it is not going to be installed
  • How To Install python 3.4 3.5 and up on Linux with wine - Working Solution
  • using Xvfb on virtual remote ssh server to have X graphical programs work
  • ssh Received disconnect from port 22:2: Too many authentication failures
  • named bind errors - DNSKEY: unable to find a DNSKEY which verifies the DNSKEY RRset and also matches a trusted key for '.'
  • OpenVZ vs LXC DIR mode poor security in LXC
  • httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/php.conf: Cannot load modules/libphp5.so into server: /lib64/libresolv.so.2: symbol __h_errno, version GLIBC_PRIVATE not defined in file libc.s