OpenVZ Solution CPT ERR: c02fa000,73 :CPT: lock fd is closed incorrectly: 1 and vps-net_add ERROR: Unable to add route ip route add 192.168.5.2 dev venet0

The only solution after trying many suggestions was to simply restart the "vz" service (definitely not preferable).

Even doing an ifdown and ifup for venet0 did not help.

ifup venet0
Bringing up interface venet0:
Configuring interface venet0:
net.ipv4.conf.venet0.send_redirects = 0
RTNETLINK answers: Network is down

Some errors from log:

CPT ERR: d2dc6000,54819 :Failed ot lookup path '/dev/shm'
CPT ERR: d2dc6000,54819 :Failed to restore mount point: dev 'tmpfs', type 'tmpfs', path '/dev/shm'
CPT ERR: d2dc6000,54819 :rst_namespace: -2

=====================


CPT ERR: f3f70000,30222 :rst_file: -2 98752
CPT ERR: f3f70000,30222 :rst_files: -2
CPT ERR: f3f70000,30222 :make_baby: -2
CPT ERR: f3f70000,30222 :rst_clone_children
unregister net_device: 'tun0' not found
unregister net_device: 'tun1' not found
unregister net_device: 'tun2' not found
unregister net_device: 'tun3' not found
unregister net_device: 'tun4' not found
kobject_add failed for tun0 with -EEXIST, don't try to register things with the same name in the same directory.
[] kobject_add+0x141/0x167
[] class_device_add+0x9d/0x3b4
[] __ve_dev_move+0x17f/0x1b4 [vzmon]
[] fini_venet+0x61/0x81 [vzmon]
[] env_cleanup+0x3e/0x185 [vzmon]
[] vzmond_helper+0x28/0x34 [vzmon]
[] vzmond_helper+0x0/0x34 [vzmon]
[] kernel_thread_helper+0x7

CPT ERR: c02fa000,73 :CPT: lock fd is closed incorrectly: 1

Starting container...
Container is mounted
Adding IP address(es): 192.168.5.2
RTNETLINK answers: No such device
vps-net_add ERROR: Unable to add route ip route add 192.168.5.2 dev venet0
Container start failed (try to check kernel messages, e.g. "dmesg | tail")
Killing container ...
Container was stopped
Container is unmounted

Solution

service vz restart


Tags:

openvz, cpt, err, fa, fd, incorrectly, vps, net_add, unable, ip, dev, venet, suggestions, restart, quot, vz, preferable, ifdown, ifup, interface, configuring, ipv, conf, send_redirects, rtnetlink, errors, dc, ot, lookup, shm, restore, mount, tmpfs, rst_namespace, rst_file, rst_files, make_baby, rst_clone_children, unregister, net_device, tun, kobject_add, eexist, register, directory, eec, class_device_add, fc, ff, __ve_dev_move, vzmon, fini_venet, env_cleanup, vzmond_helper, kernel_thread_helper, container, mounted, adding, es, kernel, dmesg, unmounted,

Latest Articles

  • Unable to mount location Failed to retrieve share list from server: Connection timed out - Samba/Linux Filesharing Not working Ubuntu Mint Linux Solution
  • How To Resize, Reduce a Video to a Specific Size and Quality Ubuntu Linux using ffmpeg
  • vi how to delete all lines in the file
  • Linux Mint / Ubuntu 20 Intel I219 NIC disconnects
  • Linux can't boot/grub boot loader screen with no options solution
  • EFI PXE grub2 Howto guide for Linux EFI PXE Booting on Debian, Mint, Ubuntu, RHEL
  • Aruba/HP/Dell IAP Wireless Controller Common Default Passwords
  • Debian, Mint Ubuntu how to remove package and associated config files
  • Linux Grub not booting the intended kernel solution in Debian, Mint, Ubuntu how to specify which kernel to boot by default
  • QEMU KVM Keyboard Problems Not Working Right Repeating Characters, Ctrl+C Copy and Paste not working right when using PS2 mouse in guests Solution
  • Linux how to compile binary with static sharedobjects embedded instead of dynamic to use on multi-distributions and avoid glibc compatiblity issues
  • /bin/sh: msgfmt: not found error solution on Linux Compilation Ubuntu Debian Mint Centos
  • Mikrotik RouterOS CHR/ISO Basic and Quick Setup Howto Guide
  • qemu 4 compilation options
  • CentOS 7 8 PXEBoot Netinstall Not Working Solution "Pane is dead "new value non-exisetnt xfs filesystem is not valid as a default fs type"
  • CentOS 6 EOL yum repo won't work Error: Cannot find a valid baseurl for repo: base Solution
  • CentOS 7 8 How To Disable SELinux
  • Wordpress How To Add Featured Image To Post in Hueman Theme
  • kdenlive full reset how to erase all config files
  • CentOS 7 8 yum error Trying other mirror. To address this issue please refer to the below wiki article